labels with class="text-link" in popups open in a new window rather than a new tab

RESOLVED DUPLICATE of bug 263433

Status

()

RESOLVED DUPLICATE of bug 263433
6 years ago
6 years ago

People

(Reporter: keeler, Assigned: keeler)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Consider toolkit/mozapps/extensions/content/extensions.xml:765:

> <xul:label anonid="warning-link" class="text-link"/>

When this is clicked, a new tab opens (given that "open new windows in a new tab instead" is set).
Compare this to browser/base/content/urlbarBindings.xml:1438:

> <xul:label xbl:inherits="href=updateLink" value="&checkForUpdates;" class="text-link"/>

When this is clicked (this is for thew new blocklisted click-to-play plugin popup notification UI - see bug 793338), a new window opens (regardless of the pref).

The difference, it seems, is that in toolkit/content/widgets/text.xml:354, window is a Window in the first case and a ChromeWindow in the second.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263433
You need to log in before you can comment on or make changes to this bug.