bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

m-c commit 6852e80e78c8 causes link error (`Accessible::Role()' isn't defined)

RESOLVED DUPLICATE of bug 798310

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 798310
6 years ago
6 years ago

People

(Reporter: Stefan, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: 

Steps to reproduce:

1. compile m-c 5fa8ef202444
2. backout http://hg.mozilla.org/mozilla-central/rev/6852e80e78c8
3. compile again


Actual results:

1. link error
... fontconfig   -lgtk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lfreetype -lz -lfontconfig -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0   -lXt -lgthread-2.0 -lfreetype -lz    -ldl  -lrt    
../../accessible/src/atk/nsMaiInterfaceTable.o: In function `getRowHeaderCB':
nsMaiInterfaceTable.cpp:(.text.getRowHeaderCB+0x67): undefined reference to `Accessible::Role()'
../../accessible/src/atk/nsMaiInterfaceTable.o: In function `getColumnHeaderCB':
nsMaiInterfaceTable.cpp:(.text.getColumnHeaderCB+0x67): undefined reference to `Accessible::Role()'
/usr/bin/ld: libxul.so: hidden symbol `Accessible::Role()' isn't defined
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
make[5]: *** [libxul.so] Error 1
3. success


Expected results:

1. success
(Reporter)

Comment 1

6 years ago
Compiler used: GCC 4.6.3
OS: Other → Linux
Hardware: Other → x86_64
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 798310
You need to log in before you can comment on or make changes to this bug.