Last Comment Bug 798141 - I can't type in Google docs if any social content has focus
: I can't type in Google docs if any social content has focus
Status: VERIFIED FIXED
[Fx17]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 799299
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 16:44 PDT by Shannon Prior
Modified: 2012-12-04 13:41 PST (History)
6 users (show)
anthony.s.hughes: in‑moztrap?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified


Attachments

Description Shannon Prior 2012-10-04 16:44:33 PDT
Hi there - if a Facebook chat window is open within my browser it wont let me click and type in to a Google doc. If I close the chat it lets me type.
Comment 1 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-04 16:49:28 PDT
I reproduced this the first time I tried it but now I can't seem to reproduce any longer. It seems that there is some certain set of conditions that reproduce this. Shannon, could you try to narrow down a reproducible set of steps to reproduce? or does this happen all the time for you?
Comment 2 Shannon Prior 2012-10-04 16:50:53 PDT
hey anthony - try sending something in a chat and then clicking back into the google doc. sorry i wasn't more specific.
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-04 16:52:53 PDT
Yeah, that's what I was trying. Reproduced once but never again it seems. However, I'm on Linux, could be Mac only?
Comment 4 Shane Caraveo (:mixedpuppy) 2012-10-04 17:05:47 PDT
I can consistently reproduce on osx.  It seems something specific to how google docs works, since I can focus and type into bugzilla just fine with chat open.  

- open google doc and type something
- open a chat and type something
- click in the doc area and try to type, the text goes into the chat box
- switch tabs to something else, then back to doc
- click in doc and you can type again
- click in chat and type
- click back into doc, you can no longer type.
Comment 5 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-04 17:09:16 PDT
(In reply to Shane Caraveo (:mixedpuppy) from comment #4)
> I can consistently reproduce on osx.  It seems something specific to how
> google docs works, since I can focus and type into bugzilla just fine with
> chat open.  

Plugin/JS related?
Comment 6 Mark LaVine [:mlavine] 2012-10-04 17:10:53 PDT
In addition to the things Shane mentioned, I also noticed that my mouse wouldn't click or select text in the chat window while I was on a Google doc page
Comment 7 Shane Caraveo (:mixedpuppy) 2012-10-04 17:21:39 PDT
I have no NPAPI plugins enabled and am able to reproduce.  Further, it has nothing to do specifically with chat.  I can repro with:

- open google doc, type something
- click in the search box at the bottom of the sidebar
- click back into google doc, try to type (it appears in the sidebar search box)
Comment 8 Mark Hammond [:markh] 2012-10-04 17:23:14 PDT
Same issue on Windows.  A "clue" this is goign to happen is the fact the caret is still blinking in the chatbox.  As soon as you switch tabs etc, the caret vanishes and things all work correctly.
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-04 17:25:56 PDT
I guess that's why I'm not seeing this on Linux; I can't see the "carat still blinking in chat" when I click in a Google Doc with the chat window open.
Comment 10 Asa Dotzler [:asa] 2012-10-05 10:38:44 PDT
This seems quite significant. I wonder how many other sites might be similarly broken. I don't think we can ship with this so marking Dx17.
Comment 11 Shane Caraveo (:mixedpuppy) 2012-10-08 17:27:21 PDT
This is a general firefox bug unrelated to socialapi.  Here is how you can reproduce the problem.

1. open the bookmarks sidebar
2. right click in an empty area and choose add new bookmark
3. enter about:home for the url (assuming you haven't changed about:home)
4. click "open in sidebar"
5. save bookmark
6. click on bookmark in sidebar

You should have the firefox/google search page.

7. open some google document and edit
8. click in the search box in the sidebar, type something
9. click in the google document, try to type something

You'll see your typing appear in the search box in the sidebar.
Comment 12 Shane Caraveo (:mixedpuppy) 2012-10-08 17:36:30 PDT
I created bug 799299 for this issue, not sure if we want to block on that.
Comment 13 Mark Hammond [:markh] 2012-10-11 16:39:33 PDT
Fixed via bug 799299
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-17 18:22:44 PDT
(fixed for 17 and 18 in bug 799299)
Comment 15 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 13:41:50 PST
Verified fixed. Flagging this for in-moztrap to create a Web-compat with Social API smoketest.

Note You need to log in before you can comment on or make changes to this bug.