Thunderbird fails to distinguish between similar e-mail addresses

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Sue Blackwell, Unassigned)

Tracking

15 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I have received a number of e-mails which were sent to similar but not identical e-mail addresses to mine.


Actual results:

Apparently Thunderbird is not sufficiently sensitive to full-stops and underscore characters in e-mail addresses.


Expected results:

I should not have received e-mails which were sent to different e-mail addresses even if they only differed from mine by a single character.
(Reporter)

Comment 1

6 years ago
Created attachment 668248 [details]
An e-mail trail showing the problem happening.

The attachment shows me replying to the sender to show that the message had reached the wrong recipient.  I tried to copy it to the intended recipient but the copy ended up in my own in-box!
Mail delivery is handled by the server, so Thunderbird cannot receive email that wasn't addressed to you.

As a side note, to truly verify the trail of a message, you would need to post the full headers of the message you received, since the important headers aren't shown by default.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.