create "correlations" service

RESOLVED DUPLICATE of bug 875990

Status

Socorro Graveyard
Middleware
RESOLVED DUPLICATE of bug 875990
6 years ago
2 years ago

People

(Reporter: rhelmer, Assigned: rhelmer)

Tracking

Details

(Assignee)

Description

6 years ago
There are some new "correlations" matviews in the database:

correlation_addons
correlation_cores
correlation_modules
correlations

These are going to be populated soon, and we'll need a middleware service to expose them.
(Assignee)

Comment 1

6 years ago
Change of plans - bug 650904 isn't actually ready. However since the old version is pretty broken and painful to implement, I am thinking of doing this:

* expose the same mware service/UI as originally planned
* provide cron job to pull and parse the existing output file https://crash-analysis.mozilla.com/crash_analysis/20121006/20121006_Firefox_17.0a2-core-counts.txt

This is similar to how the old site works, except that it does AJAX calls and parses the above file over and over in the UI code, instead of just doing it once per day per my proposal.

See https://github.com/mozilla/socorro/blob/master/webapp-php/application/controllers/correlation.php for reference.
Blocks: 683388
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Depends on: 798837
(Assignee)

Comment 2

6 years ago
Created bug 798837 to cover comment 1.

One advantage to this approach is that it's a lot less infrastructural change from the old app - it is still depending upon the old report etc. The downside is that it's a pain to parse, and a very roundabout way to do it, but at least the new UI will be insulated from that, should show the reports in a timely manner etc.
(Assignee)

Comment 3

6 years ago
Should not block staging, this is a rewrite of correlations.
No longer blocks: 788048
(Assignee)

Comment 4

5 years ago
Still needed, but going to respawn under the tracker bug 875990.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875990
Product: Socorro → Socorro Graveyard
You need to log in before you can comment on or make changes to this bug.