[camera] Switching from Camera to Video and back again does not put Camera in Preview Mode at once

RESOLVED WORKSFORME

Status

Firefox OS
Gaia
P3
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Parul Mathur, Assigned: kanru)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Otoro phone, build 2012-10-04
Git commit info: a33396
Test Case: [Camera] Go to video, go back to camera
  1.  launch camera app
  2.  go to video by pressing the video button
  3.  go back to camera by pressing the camera button
https://moztrap.mozilla.org/runtests/run/228/env/161/


Actual results:

Goes to video, then goes back to camera after the button toggling. The Camera Preview mode does not come back on again immediately. The delay is generally longer than a minute, though sometimes lasts just 7 seconds.
During this delay, the screen remains blank (dark, empty) but the bar at the bottom continues to display 3 icons: Gallery App, Camera and Video. Clicking on the Camera icon takes a photo.


Expected results:

Goes to video, then goes back to camera after the button toggling. The Camera Preview mode should be on again.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Assignee: nobody → dale
blocking-basecamp: ? → +
This is a strange one, if you click on the preview it comes up immediately

I might be able to fake a fix in gaialand, but have you got any ideas mike?
(In reply to dale from comment #1)
> 
> I might be able to fake a fix in gaialand, but have you got any ideas mike?

No, but this has been a persistent nagging problem for a while.  See bug 791711 (which has morphed into at least one other bug over its lifetime).
Assignee: dale → mhabicher
Hmm, just tried this a few times and it switched back and forth just fine.  :kanru, could this be related to the other issue you're working on?
Flags: needinfo?(kchen)
(Assignee)

Comment 4

6 years ago
Looks like exactly bug 791711 ?
Flags: needinfo?(kchen)

Updated

6 years ago
Keywords: qawanted
Priority: -- → P3
Kan-Ru: can I assign this to you, then?
Assignee: mhabicher → kchen
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791711

Comment 7

6 years ago
not a dupe of 791711, because this is about switching from camera to video button.  But regardless, cannot reproduce on the 11-14-2012 unagi build.
Keywords: qawanted
Resolution: DUPLICATE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.