B2G SMS: generic error in sending messages in some countries

RESOLVED DUPLICATE of bug 807631

Status

()

Core
DOM: Device Interfaces
P1
normal
RESOLVED DUPLICATE of bug 807631
6 years ago
6 years ago

People

(Reporter: vicamo, Assigned: vicamo)

Tracking

unspecified
B2G C1 (to 19nov)
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [LOE:L])

Attachments

(4 attachments, 2 obsolete attachments)

(Assignee)

Description

6 years ago
Bug 786782 tries to solve sending SMS problems in different countries. However, there are actually two different root cause and should not be mixed. In this issue, we deal with the case reported getting 'generic error' from rild and failing the send request.

A typical error has following snatches in radio logcat output:

> RIL <--- WMS_MSG_EVENT_SUBMIT_REPORT(139280), RID 0, MID 0 --- AMSS
> EVENT_SUBMIT_REPORT: msg mode 1 rpt status 100 cause value 28
> [RID 0] ReqList entries : Empty 
> UI <--- RIL_REQUEST_SEND_SMS (25) Complete --- RIL [RID 0, Token 86,
>     Generic Failure, Len 12 ]
(Assignee)

Comment 1

6 years ago
Ask for bb flag for the original bug 786782 has it.
blocking-basecamp: --- → ?
Whiteboard: [LOE:L]
(Assignee)

Comment 2

6 years ago
Created attachment 668278 [details]
logcat-2000.txt

Attached is logcat output captured at sending a text message of 2000 chars, 160 chars in each segment, and 14 segments in total.
(Assignee)

Comment 3

6 years ago
Created attachment 668280 [details]
logcat-radio-2000.txt

Attached is the corresponding output of rild.
(Assignee)

Comment 4

6 years ago
Created attachment 668286 [details] [diff] [review]
[debug]

This patch enables debug messages in sms related RIL components, also add a handy hack for testing long long messages. One can input "23" in message app and press send, the underlying backend will send a message of "01234567890123456789\n012" instead.
blocking-basecamp: ? → +

Updated

6 years ago
Assignee: nobody → vyang
(Assignee)

Comment 5

6 years ago
Comment on attachment 668286 [details] [diff] [review]
[debug]

Hi, could you help capturing another run of debug messages? Here are steps to make it:

1. rebuild gecko with this debug patch and flash to device
2. execute `adb logcat -b radio | tee logcat-mbarone-200.txt`
3. send a message with text message "200". You don't have to key-in 200 characters, just the string "200" and gecko will do that for you.
4. please attach the captured txt file in this issue.
Attachment #668286 - Flags: feedback?(mbarone976)

Comment 6

6 years ago
Hi,

I've tested the patch but I couldn't send the SMS. Attached the logcat info.

Comment 7

6 years ago
Created attachment 671354 [details]
Logcat output

Comment 8

6 years ago
Created attachment 671355 [details]
SMS screenshot
(Assignee)

Comment 9

6 years ago
(In reply to mbarone from comment #6)
> I've tested the patch but I couldn't send the SMS. Attached the logcat info.

I can't find "Generic Error" in your attached log. Please attach normal logcat messages as well. (adb locat | tee some-file-name-here.txt)

Beside, instead of "Generic Error" from SMSC, it seems sending huge message can crash rild/modem. I just found it in my Otoro.
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #9)
> Beside, instead of "Generic Error" from SMSC, it seems sending huge message
> can crash rild/modem. I just found it in my Otoro.

Vicamo, how large is "huge"?
Flags: needinfo?(vyang)
(Assignee)

Comment 11

6 years ago
(In reply to Andrew Overholt [:overholt] from comment #10)
> (In reply to Vicamo Yang [:vicamo][:vyang] from comment #9)
> > Beside, instead of "Generic Error" from SMSC, it seems sending huge message
> > can crash rild/modem. I just found it in my Otoro.
> 
> Vicamo, how large is "huge"?

A message of 2000 characters.
Flags: needinfo?(vyang)
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #11)
> (In reply to Andrew Overholt [:overholt] from comment #10)
> > (In reply to Vicamo Yang [:vicamo][:vyang] from comment #9)
> > > Beside, instead of "Generic Error" from SMSC, it seems sending huge message
> > > can crash rild/modem. I just found it in my Otoro.
> > 
> > Vicamo, how large is "huge"?
> 
> A message of 2000 characters.

Are 2000 character SMS messages allowed?

What do we need to move this bug toward a bit?
Flags: needinfo?(vyang)
(In reply to Andrew Overholt [:overholt] from comment #12)
> (In reply to Vicamo Yang [:vicamo][:vyang] from comment #11)
> > (In reply to Andrew Overholt [:overholt] from comment #10)
> > > (In reply to Vicamo Yang [:vicamo][:vyang] from comment #9)
> > > > Beside, instead of "Generic Error" from SMSC, it seems sending huge message
> > > > can crash rild/modem. I just found it in my Otoro.
> > > 
> > > Vicamo, how large is "huge"?
> > 
> > A message of 2000 characters.
> 
> Are 2000 character SMS messages allowed?
> 

No, at least in Telefónica supporting concatenation up to 10 SMS which is below 2000 chars. If there is a maximum size B2G supports I suggest we open a follow-up bug in the SMS application to prevent those messages being sent. Do we know which is the maximum size of SMS we can send in B2G?
(Assignee)

Comment 14

6 years ago
(In reply to Daniel Coloma:dcoloma from comment #13)
> Do we know which is the maximum size of SMS we can send in B2G?

I opened bug 806811 for this.
Flags: needinfo?(vyang)
We're marking this bug with the C1 milestone since it follows the criteria of "remaining LOE:L work" (see https://etherpad.mozilla.org/b2g-convergence-schedule).

If this work is not finished by Nov19, this bug will need an exception and will be called out at the upcoming Exec Review.
Priority: -- → P1
Target Milestone: --- → B2G C1 (to 19nov)
(Assignee)

Comment 16

6 years ago
Created attachment 681900 [details]
receivedLongsms_log.txt

You can see around line 696. It's actually bug 807631. I'm not pretty sure whether is there still any issues about multipart SMS, still confirming with brg.
Attachment #671354 - Attachment is obsolete: true
Attachment #671355 - Attachment is obsolete: true

Comment 17

6 years ago
Tested again in Spain with Movistar SIM and Unagi.

Now it works, we can sending and receiving concatenated sms with 200 characters. 

Build tested:
      * Gecko-76848b5
      * Gaia-1c884f4
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 807631
(Assignee)

Updated

6 years ago
Attachment #668286 - Flags: feedback?(mbarone976)
You need to log in before you can comment on or make changes to this bug.