[settings] after unpairing devices, the Bluetooth subheading still says "Galaxy Nexus, +1 more"

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: dietrich, Assigned: rexboy)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

6 years ago
OS: Mac OS X → Gonk
Hardware: x86 → ARM

Updated

6 years ago
Component: Gaia → Gaia::Settings
Hi, I tried and found this issue seems fixed. Can someone test again? Thanks.

Updated

6 years ago
Assignee: nobody → ehung
blocking-basecamp: --- → ?
blocking-basecamp: ? → +
Priority: -- → P2

Updated

6 years ago
Flags: needinfo?(dietrich)
(Reporter)

Comment 2

6 years ago
Yes can still reproduce.

STR:

1. pair a device
2. unpair from firefox os
3. go back to Settings main screen

Expected: "no devices paired"

Actual: device name

If you kill Settings and re-open, the proper message is displayed.
Flags: needinfo?(dietrich)
(In reply to Dietrich Ayala (:dietrich) from comment #2)
> Yes can still reproduce.
> 
> STR:
> 
> 1. pair a device
> 2. unpair from firefox os
> 3. go back to Settings main screen
> 
> Expected: "no devices paired"
> 
> Actual: device name
> 
> If you kill Settings and re-open, the proper message is displayed.

Yes, I can reproduce by following Dietrich's STR.

I found that the result is correctly displayed if:

  (1) Pair more than 1 device
  (2) Unpair some of them but don't empty paired devices
  (3) Go back to Settings main screen, you should see the message is correctly displayed.

So it looks like there is a bug of displaying the message after unpairing the last device.
I'm working on this due to earlier discussion with Evelyn.
Assignee: ehung → rexboy
Created attachment 685937 [details]
Fix: Show "no paired" on main menu when all pairing devices are removed.

I put a patch here.  It looks like we just need to update the subheading when devices changes to 0.
Attachment #685937 - Flags: review?(ehung)

Comment 6

6 years ago
Comment on attachment 685937 [details]
Fix: Show "no paired" on main menu when all pairing devices are removed.

r=me, thanks for your great work!
Attachment #685937 - Flags: review?(ehung) → review+
https://github.com/mozilla-b2g/gaia/pull/6643
I've merged it here.  Thank you for reviewing, Evelyn!

Notice that this patch also resolved the layout problem reported in bug 815939.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 812424

Comment 9

6 years ago
Verified fixed on Unagi build 20130103070201. Within the bluetooth settings had 3 separate devices in the pairing list. The Settings main page displayed the correct message upon unpairing each device one at a time.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.