Crash Report [@ java.lang.NoSuchMethodError: android.content.SharedPreferences$Editor.apply at org.mozilla.gecko.WebAppAllocator.findAndAllocateIndex(WebAppAllocator.java) ]

RESOLVED DUPLICATE of bug 786826

Status

()

--
critical
RESOLVED DUPLICATE of bug 786826
7 years ago
7 years ago

People

(Reporter: ioana.chiorean, Unassigned)

Tracking

({crash})

17 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
This bug was filed from the Socorro interface and is 
report bp-e2fb95e3-2522-49fa-8f2b-11cb22121005 .
=============================================================
(Reporter)

Comment 1

7 years ago
0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:19
1 	libc.so 	__swrite 	
2 		@0x10003 	
3 	libdvm.so 	dvmMterpStdBail 	
4 	libdvm.so 	dvmMterpStdBail 	
5 		@0x21c 	
6 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash 	APKOpen.cpp:301
7 	libdvm.so 	dvmPlatformInvoke 	
8 	libdvm.so 	dvmCallJNIMethod_general 	
9 	libdvm.so 	dvmResolveNativeMethod 	
10 	libdvm.so 	dvmAsmSisterStart 	
11 	libdvm.so 	dvmMterpStd 	
12 	libdvm.so 	dvmInterpret 	
13 	libdvm.so 	dvmCallMethodV 	
14 	libdvm.so 	dvmCallMethod 	
15 	libdvm.so 	dvmRaiseThreadPriorityIfNeeded 	
16 	libdvm.so 	dvmDetachCurrentThread 	
17 	libdvm.so 	dvmDetachCurrentThread 	
18 	libc.so 	__thread_entry 	
19 	libc.so 	pthread_create

Steps done:
1. Go to marketplace.mozilla.org
2. Tap Log in
There's already a bug filed for that.

For Java signatures, only the Java stack trace in the crash report header is useful.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786826
(Reporter)

Comment 3

7 years ago
(In reply to Scoobidiver from comment #2)
> There's already a bug filed for that.
> 
> For Java signatures, only the Java stack trace in the crash report header is
> useful.
> 
> *** This bug has been marked as a duplicate of bug 786826 ***

The other one is marked resolved fixed - shouldn't it be re-open then?
(In reply to Ioana Chiorean from comment #3)
> The other one is marked resolved fixed - shouldn't it be re-open then?
It's marked fixed for the target milestone, Firefox 18. It's not currently fixed in Aurora.
Note that the patch for Aurora is waiting for uplift.
You need to log in before you can comment on or make changes to this bug.