The element focused after pressing <tab> in a comment box should be the "submit comment" button.

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: Needinfo
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Assigned: dkl)

Tracking

Production

Details

(Reporter)

Description

6 years ago
(Sorry if this is the wrong component.)

Right now, when you press <tab> in a comment box, you focus the "need additional information" checkbox.

Submitting a comment is much more common an operation than asking for additional information, so I think we should optimize the UI for the former.

I realize that you can probably just press enter while the "need additional information" checkbox is selected to submit the form.  But I've seen at least one person now unset his own info request flag presumably by pressing <space> here.
Component: User Interface → Extensions: Needinfo
Duplicate of this bug: 800308
Assignee: nobody → glob
Assignee: glob → dkl
(Assignee)

Comment 2

6 years ago
Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.0
modified extensions/Needinfo/template/en/default/bug/needinfo.html.tmpl
Committed revision 8355.

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2
modified extensions/Needinfo/template/en/default/bug/needinfo.html.tmpl
Committed revision 8377.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.