M6 aprunner gives blank mail config form then aborts on first run

VERIFIED INVALID

Status

SeaMonkey
MailNews: Account Configuration
P3
blocker
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: David Woolley, Assigned: Grace Bush)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When first run, aprunner puts out a form for email customisation.  All the
fields are blank, including the default directory.  Even if you fill them in, it
then crashes as follows and you are left back at square one.

I did have M4 installed previously, but after the first abort I delete the
Mozilla registry, and did so after each subsequent abort.

This is the last screen full of diagnostics.

Name does not exist
Name Value: FullName    David Woolley
Inside SetValue
Name does not exist
Name Value: Email       djw@bts.co.uk
Inside SetValue
Name does not exist
Name Value: SMTP        mailgate.bts.co.uk
before for loop
DATA IS: ProfileName=djw%ProfileDir=\fred\mozilla%FullName=David Woolley%SMTP=ma
ilgate.bts.co.uk%
calling javascript reflection
!profileCore
Created nsProfileCore
!profileCore
after ! yes profileCore in if loop
yes profileCore
Entered Create Profile RoutineCreated nsToolkitCore
JavaScript error: parent is not defined
URL: file:///D|/fred/X86REL/res/profile/navigationFinish.xul LineNo: 49
(Reporter)

Comment 1

19 years ago
For clarification:  I ran it twice before first clearing the registry, which
is why I say that one cannot get past this stage.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 2

19 years ago
Currently, apprunner does not automatically start up when profile manager is
completed. (that is coming soon). After profile data is entered, you are
returned to console if using command line or to ?? if using icon. Rerun
apprunner using either method and the app will launch.
Marking invalid-See big 7327 for similar situation
(Reporter)

Comment 3

19 years ago
It looks like the underlying problem was failing to prompt with a default
directory, even though the text implies that there is one.  I presume it
is this which caused it to fail when I ran apprunner the second time.

Subsequently, I reset the system state before each attempt, that a second
run would not have worked, as I thought I'd established that a second run
wouldn't solve the problem.
(Assignee)

Comment 4

19 years ago
The form you see is a preliminary UI for Profile Manager which should be hooked
up to apprunner by next week. See also bug 7016-the launching should be
transparent.

Sean,
This is a Profile Manager bug but I cannot change component or assigned-does it
have to be reopened to do that?
(Assignee)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Assignee)

Updated

19 years ago
Assignee: ssu → racham
Status: REOPENED → NEW
(Assignee)

Comment 5

19 years ago
Unable to change component to Profile Manager, this is not Install Wizard bug.
Changing assignee, remarking invalid
Launch occurs after creating a profile now (build 1999061308)
(Assignee)

Comment 6

19 years ago
Unable to change component to Profile Manager, this is not Install Wizard bug.
Changing assignee, remarking invalid
Launch occurs after creating a profile now (build 1999061308)
(Assignee)

Updated

19 years ago
Assignee: racham → gbush
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
(Assignee)

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

19 years ago
Target Milestone: M7

Updated

19 years ago
Component: Install Wizard → Account Manager
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.