Closed Bug 798493 Opened 7 years ago Closed 11 months ago

Incorrect updating of ByteArray memory when passed between worker threads

Categories

(Tamarin Graveyard :: Virtual Machine, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: michsmit, Assigned: michsmit)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Send a non-shared ByteArray from one worker thread to another over a channel.


Actual results:

This creates a copy of the ByteArray, which gets associated with a GC object when the ByteArray is received on the channel. The GC doesn't get notified of the memory increase due to the new ByteArray, however it does get notified of the decrease in memory when it's destroyed. This can cause issues with calculating GC pressure.


Expected results:

When the ByteArray is received (through GetAtom()), it should notify the GC of the memory increase.
Assignee: nobody → michsmit
QA Contact: dschaffe
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch PatchSplinter Review
Changelist 1122494
Attachment #670042 - Flags: superreview?
Attachment #670042 - Flags: review?(jasowill)
changeset: 7564:f5191c18b0e4
user:      Dan Schaffer <Dan.Schaffer@adobe.com>
summary:   Bug 798493: Incorrect updating of ByteArray when passed between worker threads (p=michsmi,r=jasowill)

http://hg.mozilla.org/tamarin-redux/rev/f5191c18b0e4
Attachment #670042 - Flags: superreview?
Attachment #670042 - Flags: review?(jasowill)
Tamarin is a dead project now. Mass WONTFIX.
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → WONTFIX
Tamarin isn't maintained anymore. WONTFIX remaining bugs.
You need to log in before you can comment on or make changes to this bug.