If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Modern skin no longer uses smart-scroll prefs

VERIFIED FIXED

Status

SeaMonkey
Themes
--
major
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Joe Hewitt (gone))

Tracking

({regression})

Trunk
PowerPC
Mac System 9.x
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The old modern skin would pick up the user's smart-scroll prefs on mac (double 
arrows, etc). the new modern ignoes them. classic still works fine.
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.1, nsbeta1, nsmac1, regression
(Assignee)

Comment 1

17 years ago
This is fixed by the patch in bug 78379.

Someone care to super-review that so I can land it today?

*** This bug has been marked as a duplicate of 78379 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified Dupe...
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
reopening. this isn't fixed on 5/14/01
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

17 years ago
hewitt says he has a patch forthcoming
(Assignee)

Comment 5

17 years ago
Created attachment 34441 [details] [diff] [review]
patch to fix
(Reporter)

Comment 6

17 years ago
yup, this fixes it.

Comment 7

17 years ago
I presume that the scrollbar.xml#scrollbar binding does all the good stuff?

sr=sfraser
(Assignee)

Comment 8

17 years ago
fixed
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
Verified the patch.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.