Closed Bug 798542 Opened 8 years ago Closed 8 years ago

the 18a1 (2012-10-05) Nightly version throws a javascript type error when trying to set a dom option object to null

Categories

(Firefox :: Untriaged, defect)

18 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 797113

People

(Reporter: chris.pearson, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121005030609

Steps to reproduce:

var selbox = $('#selboxid')[0];
var selboxoptions = selbox.options;
selboxoptions[0] = null;


Actual results:

'TypeError: Value not an object' error thrown on the 3rd line


Expected results:

the select box option at postion 0 should be removed from the dom without error.
Hardware: x86 → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797113
You need to log in before you can comment on or make changes to this bug.