[Email] Clearing the search field by hitting the "x" icon in the search field should reset the search results list

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
P3
normal
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: tchung, Assigned: robert.sajdok)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: interaction [UX-P3])

Attachments

(1 attachment, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
jrburke
: review+
Details | Review | Splinter Review
(Reporter)

Description

6 years ago
In search, when you start typing a keyword, it will populate the list of returned results matching the search.  however, once you clear the search box (hit the X), the list of search results is still present. 

It should remove the items you've previously searched for.

Environment:
- 10/5 daily otoro build
- gaia: ca1f327d5acc198bb4be62fa51db2c039032c9ce
- gecko: ddc8eeb3f9b9ee04d9f74b4f60522eb4530a4a6f

Repro:
1) launch email and add an account (gmail)
2) click search icon and start typing in chars that will return results you know
3) when results are displayed, click the X to cancel the search terms
4) Verify your search results from before are still present in the results page

Expected:
- clearing the search string should remove the previous search results page

Actual:
- previous search results remains on the page, despite clearing the search.
(Reporter)

Comment 1

6 years ago
probably blocking- as it doesnt break functionality unless its privacy related. but just getting on the radar.
blocking-basecamp: --- → ?
blocking-basecamp: ? → -

Updated

6 years ago
Keywords: polish
Priority: -- → P3

Comment 2

6 years ago
I can still reproduce this bug.

[UX-P3] As it is ubiquitous behavior with automated search that clearing the search string from the search box clears the search results. But i do not believe this bug should block as the user can easily recover from the error of the search results being displayed by: 

1) retyping in the search box to generate a new result set
2) press the cancel button to view the full list of emails in their inbox
Whiteboard: interaction [UX-P3]
The problem is that we aren't getting an event from clearing the search.  We need to listen to the click on the "reset" button or hook an event on the form itself or something like that.
This still happens.
Duplicate of this bug: 1113424
Summary: [Email] Clearing the search field should reset the search results list → [Email] Clearing the search field by hitting the "x" icon in the search field should reset the search results list
(Assignee)

Updated

3 years ago
Assignee: nobody → robert.sajdok
Created attachment 8567007 [details] [review]
[gaia] rsajdok:bug#798704 > mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
Created attachment 8567010 [details] [review]
Proposed fix.
Attachment #8567010 - Flags: review?(jrburke)
Comment on attachment 8567010 [details] [review]
Proposed fix.

Right general approach, have a suggestion in the pull request to reduce the size of the cancel function.
Attachment #8567010 - Flags: review?(jrburke)
(Assignee)

Updated

3 years ago
Attachment #8567010 - Flags: review?(jrburke)
Comment on attachment 8567007 [details] [review]
[gaia] rsajdok:bug#798704 > mozilla-b2g:master

Looks and works good, thank you very much!

Gaia is now using a tool called autolander to help with pull requests:

https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Submitting_a_Gaia_patch#Easy_patch_submission_with_Autolander

You might have noticed that it attached the pull request to this bug very soon after you submitted the pull request. Since the comment mentions the bug number in the expected format, this happens automatically now.

So I am going to r+ the attachment that autolander created for the ticket (which just points to the same pull request). 

For future pull requests, if you continue to follow the pull request title and formatting as mentioned in the link above, then you can just flag me for review for that attachment on the bug that autolander creates.

That is the reason for me commenting and r+'ing the first attachment. Since this is r+ now, I can add a checkin-needed and the autolander will handle confirming the patch still works on master and will land it for us.

Thank you very much for the continued pull requests, it is great to see these issues fixed to improve the overall feel of the app!
Attachment #8567007 - Flags: review+

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Attachment #8567010 - Flags: review?(jrburke)

Updated

3 years ago
Attachment #8567010 - Attachment is obsolete: true

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.