Compiler tautology errors in SIPCC

RESOLVED DUPLICATE of bug 799071

Status

()

Core
WebRTC: Signaling
RESOLVED DUPLICATE of bug 799071
6 years ago
6 years ago

People

(Reporter: ekr, Assigned: ehugg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 668741 [details]
demo

The problem here is comparing an enum to an integral value that is not in the enum's range. I have attached a sloppy patch that identifies the enums in question, but if you compile with clang-3.2 you will see them.
(Assignee)

Updated

6 years ago
Assignee: nobody → ethanhugg
This is where reset_type comes from:

// define device reset types
typedef enum {
    DEVICE_RESET   = CC_DEVICE_RESET,
    DEVICE_RESTART = CC_DEVICE_RESTART,
    ICMP_UNREACHABLE_RESET = CC_DEVICE_ICMP_UNREACHABLE
} DeviceResetType;

See new patch on bug 799071; we probably want to dup this to that

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799071
You need to log in before you can comment on or make changes to this bug.