Fix "Another document with this slug" error message

RESOLVED FIXED

Status

Mozilla Developer Network
Localization
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Olivier Audard, Assigned: davidwalsh)

Tracking

Details

(Whiteboard: u=contributor p= c=Localization)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I created a new French translation page and saved it.
Then I edited the newly created page and saved again.

Original Page: https://developer.mozilla.org/en-US/docs/HTML/Element/div
Translated Page: https://developer.mozilla.org/fr/docs/HTML/Element/div


Actual results:

I got an error message : "Un autre document avec cet identifiant d'URL existe déjà." (ie: Another document with this URL identifier already exists).

I get the same error if I try to edit any other translation page. But it seems that it only occurs with translation UI.


Expected results:

Translated page should have been updated.
Raymond, can you confirm this?
Summary: Can't edit translated page → "Another document with this slug" appears after editing translated page
Raymond, see comment 1.
Duplicate of this bug: 798410
Whiteboard: s=2012-10-30 u=contributor
Whiteboard: s=2012-10-30 u=contributor → s=2012-10-30 u=contributor p=
Priority: -- → P1
Whiteboard: s=2012-10-30 u=contributor p= → s=2012-10-30 u=contributor p= c=Localization
(Assignee)

Comment 4

5 years ago
Editing the following page shows a "Page with this slug already exists":

https://developer.mozilla.org/fr/docs/HTML

No other pages currently have this issue.  After looking into admin, I found this that there is a document with "/HTML" as the slug, and another with "HTML" as the slug.  The document with the "/HTML" slug looks to be some sort of legacy document.

Can we simply delete said document?
(Assignee)

Updated

5 years ago
Duplicate of this bug: 809539
(Assignee)

Updated

5 years ago
Depends on: 809617
(Assignee)

Updated

5 years ago
QA Contact: dwalsh
Blocks: 809617
No longer depends on: 809617
Summary: "Another document with this slug" appears after editing translated page → Fix "Another document with this slug" error message
Whiteboard: s=2012-10-30 u=contributor p= c=Localization → u=contributor p= c=Localization
(Assignee)

Updated

5 years ago
Assignee: nobody → dwalsh
fixed by bug 809617
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.