gradients in SVG glyphs change when zooming the page

RESOLVED FIXED in mozilla21

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: heycam, Assigned: eflores)

Tracking

Trunk
mozilla21
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
Load layout/reftests/text-svgglyphs/svg-glyph-objectgradient.svg and zoom the page.  Notice that the gradients seem to be rendered with their colours in their original positions.  There probably just needs to be a scale by presContext->AppUnitsToFloatCSSPixels(presContext->AppUnitsPerDevPixel()) somewhere.
Assignee: nobody → eflores
Duplicate of this bug: 798842
Posted patch FixSplinter Review
No idea what I was thinking when I wrote that originally.
Attachment #671661 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/2ef4fa34d80e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.