Closed Bug 798863 Opened 9 years ago Closed 9 years ago

Android crash in mozilla::FrameLayerBuilder::CheckDOMModified

Categories

(Core :: Layout, defect)

18 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 803826
Tracking Status
fennec 18+ ---

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash])

Crash Data

It first appeared in 18.0a1/20121004. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=635fcc11d2b1&tochange=4cb8f88213f5

Signature 	mozilla::FrameLayerBuilder::CheckDOMModified More Reports Search
UUID	14e5d309-b730-4fbb-a9a4-c54012121007
Date Processed	2012-10-07 01:58:36
Uptime	7546
Last Crash	8.2 hours before submission
Install Age	2.7 hours since version was first installed.
Install Time	2012-10-06 23:23:17
Product	FennecAndroid
Version	18.0a1
Build ID	20121006134717
Release Channel	nightly
OS	Android
OS Version	0.0.0 Linux 2.6.39.4 #1 SMP PREEMPT Fri Jun 15 17:53:45 CST 2012 armv7l asus/US_epad/TF101:4.0.3/IML74K/US_epad-9.2.1.27-20120615:user/release-keys
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0x8
App Notes 	
AdapterDescription: 'NVIDIA Corporation -- NVIDIA Tegra -- OpenGL ES 2.0 14.01002 -- Model: Transformer TF101, Product: US_epad, Manufacturer: asus, Hardware: ventana'
EGL? EGL+ GL Context? GL Context+ GL Layers? GL Layers+ 
asus Transformer TF101
asus/US_epad/TF101:4.0.3/IML74K/US_epad-9.2.1.27-20120615:user/release-keys
EMCheckCompatibility	True
Adapter Vendor ID	NVIDIA Corporation
Adapter Device ID	NVIDIA Tegra
Device	asus Transformer TF101
Android API Version	15 (REL)
Android CPU ABI	armeabi-v7a

Frame 	Module 	Signature 	Source
0 	libxul.so 	mozilla::FrameLayerBuilder::CheckDOMModified 	FrameLayerBuilder.cpp:3265
1 	libxul.so 	mozilla::FrameLayerBuilder::DrawThebesLayer 	FrameLayerBuilder.cpp:3097
2 	libxul.so 	mozilla::layers::BasicThebesLayer::PaintThebes 	BasicThebesLayer.cpp:139
3 	libxul.so 	mozilla::layers::BasicLayerManager::PaintSelfOrChildren 	BasicLayerManager.cpp:824
4 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer 	BasicLayerManager.cpp:943
5 	libxul.so 	mozilla::layers::BasicLayerManager::PaintSelfOrChildren 	BasicLayerManager.cpp:839
6 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer 	BasicLayerManager.cpp:943
....
22 	libxul.so 	mozilla::layers::BasicLayerManager::EndTransactionInternal 	BasicLayerManager.cpp:585
23 	libxul.so 	mozilla::layers::BasicLayerManager::EndTransaction 	BasicLayerManager.cpp:508
24 	libxul.so 	mozilla::layers::BasicShadowLayerManager::EndTransaction 	BasicLayerManager.cpp:1129
25 	libxul.so 	nsDisplayList::PaintForFrame 	nsDisplayList.cpp:1099
26 	libxul.so 	nsDisplayList::PaintRoot 	nsDisplayList.cpp:966
27 	libxul.so 	nsLayoutUtils::PaintFrame 	nsLayoutUtils.cpp:1835
28 	libxul.so 	PresShell::Paint 	nsPresShell.cpp:5323
29 	libxul.so 	nsViewManager::ProcessPendingUpdatesForView 	nsViewManager.cpp:436
30 	libxul.so 	nsViewManager::ProcessPendingUpdates 	nsViewManager.cpp:1210
31 	libxul.so 	nsRefreshDriver::Tick 	nsRefreshDriver.cpp:845
32 	libxul.so 	mozilla::RefreshDriverTimer::TimerTick 	nsRefreshDriver.cpp:156
33 	libxul.so 	nsTimerImpl::Fire 	nsTimerImpl.cpp:473
34 	libxul.so 	nsTimerEvent::Run 	nsTimerImpl.cpp:556 
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3AFrameLayerBuilder%3A%3ACheckDOMModified
Now more reports at: https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3AFrameLayerBuilder%3A%3ACheckDOMModified%28%29
Crash Signature: [@ mozilla::FrameLayerBuilder::CheckDOMModified] → [@ mozilla::FrameLayerBuilder::CheckDOMModified] [@ mozilla::FrameLayerBuilder::CheckDOMModified()]
Whiteboard: [native-crash]
To clarify comment 1, from 19.0a1/20121009, every crash signatures on Linux have a Windows look.
It started spiking in Aurora and Nightly on October 18 with the release of https://blog.mozilla.org/futurereleases/2012/10/18/firefox-marketplace-aurora-release-2/
tracking-fennec: --- → ?
Keywords: topcrash
Summary: crash in mozilla::FrameLayerBuilder::CheckDOMModified → Android crash in mozilla::FrameLayerBuilder::CheckDOMModified
Chris and Scott: Does this look familiar to either of you? It's currently #5 crasher on Fx18 and #9 on Fx19.
tracking-fennec: ? → 18+
Is this a dupe of bug 803826?
(In reply to Chris Lord [:cwiiis] from comment #5)
> Is this a dupe of bug 803826?

Very possible. Bug 803826 landed on m-c on 10-23 and I do not see any crashes for 10-24 or beyond.

Duping, but asking for uplift to 18 in bug 803826.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 803826
You need to log in before you can comment on or make changes to this bug.