If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cmd-Click doesn't open link in new window

VERIFIED DUPLICATE of bug 79548

Status

SeaMonkey
UI Design
--
critical
VERIFIED DUPLICATE of bug 79548
17 years ago
13 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: joki (gone))

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [br])

(Reporter)

Description

17 years ago
- go to any webpage
- cmd-click a link

expected:
- link opens in new window

actual:
- nothing happens.

this is a serious regression
(Reporter)

Comment 1

17 years ago
cc'ing jst to see if maybe he broke it.

this is a beta stopper.
Keywords: correctness, nsbeta1, nsmac1, regression
(Reporter)

Comment 2

17 years ago
i don't think neeti is the right owner, but this has to do with url dispatching. 
who should own this?

Comment 3

17 years ago
cc url dispatching folks.

Comment 4

17 years ago
well, I implemented this originally, but I haven't touched it since.  hurrah -- 
another regression!

I'm inclined to blame joki because he touched this directly for bug 68568 (see 
http://bonsai.mozilla.org/cvslog.cgi?
file=mozilla/content/html/content/src/nsGenericHTMLElement.cpp).  I don't see 
anything outright wrong with his change, but I don't have a build handy to help 
me along.

If anyone wants to start tracing this, we ignore modified link clicks at 
http://lxr.mozilla.org/seamonkey/source/content/html/content/src/nsGenericHTMLEl
ement.cpp#1176 so that we can handle them in js at 
http://lxr.mozilla.org/seamonkey/source/xpfe/communicator/resources/content/cont
entAreaClick.js#136
Assignee: neeti → joki
OS: Mac System 9.x → All
Hardware: Macintosh → All

Updated

17 years ago
Keywords: mozilla0.9.1
Whiteboard: [br]
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 79548 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Status: RESOLVED → VERIFIED
Component: Networking → XP Apps
QA Contact: tever → sairuh

Comment 6

16 years ago
VERIFIED:
"command-click" means something else to mac users, but it's the same problem.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.