Closed Bug 798931 Opened 7 years ago Closed 7 years ago

[Azure] Rendering Issues in Chrome UI Elements

Categories

(Core :: Graphics: Text, defect)

17 Branch
All
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18
Tracking Status
firefox17 + verified
firefox18 + verified

People

(Reporter: xtc4uall, Assigned: bas.schouten)

References

Details

(Keywords: regression, verifyme)

Attachments

(2 files)

See Screenshot.

Setting gfx.canvas.azure.enabled;false / gfx.content.azure.enabled;false does not show the Issue.

Range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9f677c2bb33d&tochange=ecd4c4304219

=> Probably by Bug 784382

  Graphics

        Adapter Description
        ATI Radeon HD 4800 Series

        Adapter Drivers
        aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64

        Adapter RAM
        512

        ClearType Parameters
        Gamma: 1800 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400

        Device ID
        0x9442

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17789)

        Driver Date
        5-7-2012

        Driver Version
        8.961.3.0

        GPU #2 Active
        false

        GPU Accelerated Windows
        1/1 Direct3D 10

        Vendor ID
        0x1002

        WebGL Renderer
        no information

        AzureCanvasBackend
        direct2d

        AzureContentBackend
        direct2d

        AzureFallbackCanvasBackend
        cairo
Forgot to add: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121007030539
OS: All → Windows 7
I can't reproduce it on 64-bit Windows 7 with Intel GMA 4500M HD.
Version: Trunk → 18 Branch
(In reply to Scoobidiver from comment #2)
> I can't reproduce it on 64-bit Windows 7 with Intel GMA 4500M HD.
I talked too fast. Clicking the Firefox button is enough to reproduce it.
The funny fact is if you switch to another application window then you come back to Nightly, the rendering is back to normal.
Duplicate of this bug: 798959
In local build
last good: d3afcd4f3cc0
first bad: 13ec2ee2b447
Triggered by:
13ec2ee2b447	Bas Schouten — Bug 784382 - Part 2: Use new ID2D1DeviceContext interface in Azure. r=jrmuizel
For me, minimizing/restoring also returns UI font to normal rendering.
Assignee: nobody → bas.schouten
BTW thanks Alice for being amazing as usual
Found the problem. Creating a patch.
This is odd, our canvas tests on Aurora caught this issue without a problem. Our tests on m-c don't seem to have caught it, which is why Try didn't show it. I wonder why.
Let's get this fixed before it goes to Aurora. Then I'll investigate why test_canvas didn't catch this.
Attachment #669040 - Flags: review?(roc)
Version: 18 Branch → 17 Branch
Duplicate of this bug: 799028
https://hg.mozilla.org/mozilla-central/rev/c28cc500c239
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Is it possible to get a respin for this? It's a pretty nasty issue and installing a hourly would mess up the update channel setting.
I'd also love for a respin
Duplicate of this bug: 799123
It should be uplifted to Aurora ASAP.
(In reply to Scoobidiver from comment #18)
> It should be uplifted to Aurora ASAP.

I thought Ed got this into m-c before the merge? Was he too late?
Yes, about 18 minutes too late according to the pushlogs.
(In reply to Bas Schouten (:bas) from comment #19)
> (In reply to Scoobidiver from comment #18)
> > It should be uplifted to Aurora ASAP.
> I thought Ed got this into m-c before the merge? Was he too late?
I meant Aurora 17 because of the uplift of bug 784382.
(In reply to annaeus from comment #15)
> Is it possible to get a respin for this? It's a pretty nasty issue and
> installing a hourly would mess up the update channel setting.

You could just disable hardware acceleration until you update to tomorrow's nightly.
There will be a bunch of filed bugs (already 3 dupes for one day in Trunk!) if it doesn't land before 17.0b1.
(In reply to Scoobidiver from comment #18)
> It should be uplifted to Aurora ASAP.

Looks like it was already a part of https://hg.mozilla.org/releases/mozilla-aurora/rev/b13f3bd4de37 from bug 784382.
Duplicate of this bug: 799113
Duplicate of this bug: 799446
Verified on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 beta 2.

No graphical problems/glitches when switching tabs/windows in 17.0 beta 2 on Windows 7. Also tried with Hardware acceleration on/off.
(In reply to Virgil Dicu [:virgil] [QA] from comment #27)
> Verified on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0
> Firefox/17.0 beta 2.
> 
> No graphical problems/glitches when switching tabs/windows in 17.0 beta 2 on
> Windows 7. Also tried with Hardware acceleration on/off.

Same result for 18 b1. Tried HWA on/off with tab/window switching.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0
You need to log in before you can comment on or make changes to this bug.