Closed Bug 798979 Opened 9 years ago Closed 9 years ago

media/webrtc/signaling/src/sipcc/core/ccapp/ccprovider.c:1914:25: error: comparison of literal 5 with expression of type 'cc_line_reg_state_t' is always false [-Werror,-Wtautological-constant-out-of-range-compare]

Categories

(Core :: WebRTC, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 798982

People

(Reporter: gps, Unassigned)

Details

I pulled m-c today and tried to build with a LLVM/Clang SVN build from a week or two ago and got the following compiler errors:

/Users/gps/src/mozilla-central-hg/media/webrtc/signaling/src/sipcc/core/ccapp/ccprovider.c:1914:25: error: comparison of literal 5 with expression of type 'cc_line_reg_state_t' is always false [-Werror,-Wtautological-constant-out-of-range-compare]
        if(gCCApp.state == (int) CC_INSERVICE)
           ~~~~~~~~~~~~ ^  ~~~~~~~~~~~~~~~~~~
/Users/gps/src/mozilla-central-hg/media/webrtc/signaling/src/sipcc/core/ccapp/ccprovider.c:1919:26: error: comparison of literal 5 with expression of type 'cc_line_reg_state_t' is always true [-Werror,-Wtautological-constant-out-of-range-compare]
            gCCApp.state != (int) CC_INSERVICE )
            ~~~~~~~~~~~~ ^  ~~~~~~~~~~~~~~~~~~

I'm now building LLVM/Clang SVN HEAD and will attempt a clobber to see if the error goes away.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 798982
You need to log in before you can comment on or make changes to this bug.