Closed Bug 798982 Opened 8 years ago Closed 8 years ago

Wrong enum type in CCAppGlobal_t/gCCApp

Categories

(Core :: WebRTC: Signaling, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: jesup, Assigned: jesup)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Attached patch FixSplinter Review
CCAppGlobal_t should have a cc_reg_state_t state, not a cc_line_reg_state_t state.  All uses are enums from cc_reg_state_t.

Newer clangs (gps runs a pull from their SVN) complain about the type mismatch.
Attachment #668979 - Flags: review?(ethanhugg)
Duplicate of this bug: 798979
Attachment #668979 - Flags: review?(ethanhugg) → review+
https://hg.mozilla.org/mozilla-central/rev/7abf134ad340
Assignee: nobody → rjesup
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.