Appcache incorrectly handles 301 redirects to outside domains

RESOLVED WONTFIX

Status

()

Core
Networking: Cache
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: Patrick Gillespie, Unassigned)

Tracking

18 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4

Steps to reproduce:

In respect to offline web apps, it appears as if Firefox and Chrome significantly differ in how they handle redirects to outside domains. I put together a quick test case:

http://patrickgillespie.com/fallback-test-1/index.htm

Clicking the first link should take you to google.com. In Chrome, this occurs. In FireFox, you are instead taken to the fallback page.

The manifest file looks like this:

---
CACHE MANIFEST
# Last updated: 2012.10.08

fallback.htm

FALLBACK:
old-content.php fallback.htm
old-content2.php fallback.htm

NETWORK:
*
---


Actual results:

The index.htm file in the test case links to two pages, both of which do redirects. The first redirect goes to an outside domain (google.com), while the second one is to a page on the existing domain. Chrome and Safari accepted the 301 redirects in both instances, FireFox, however, loads the fallback page for the link that's a redirect to an outside domain. 


Expected results:

The redirect should have worked instead of loading the fallback page. I believe the current behavior to be a bug for the following reasons:

- A site may need to change domains in the future. The site would want to redirect old links to new links, and they'd expect users get redirected. Instead the users would get the old domain's fallback page. 
- It don't allow a site to redirect to another site to be logged in.
- It is inconsistent with how Chrome and Safari handle the issue.
Component: Untriaged → Web Apps
QA Contact: jsmith

Updated

5 years ago
Component: Web Apps → Networking: Cache
Product: Firefox → Core
QA Contact: jsmith
(Reporter)

Comment 1

5 years ago
I brought this issue up on the W3C's fixing-appcache mailing list. One of the members provided some information that may be useful:

"
I can explain why in Chrome and Safari the redirect you've setup is followed. In a nutshell, because it's a frame navigation and not a subresource load. There are subtle differences in how the those two cases are specified to be handled. Main resource loads are described in mind-numbing detail here....
     http://www.whatwg.org/specs/web-apps/current-work/multipage/history.html#navigating-across-documents
and subresource loads here...
    http://www.whatwg.org/specs/web-apps/current-work/multipage/offline.html#changesToNetworkingModel
Sounds to me like FireFox does not make this distinction and has a bug.
"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.