Last Comment Bug 799067 - Compile error: calDateTime.cpp(636) and calDateTime.cpp(641) : error C2660: 'js_DateIsValid' / 'js_DateGetMsecSinceEpoch' : function does not take 2 arguments
: Compile error: calDateTime.cpp(636) and calDateTime.cpp(641) : error C2660: '...
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: 2.0
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
Depends on: 793076
Blocks: 794477
  Show dependency treegraph
 
Reported: 2012-10-08 03:32 PDT by Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
Modified: 2012-10-08 09:15 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix - v1 (785 bytes, patch)
2012-10-08 05:18 PDT, Philipp Kewisch [:Fallen]
ssitter: review+
Details | Diff | Splinter Review

Description Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-10-08 03:32:27 PDT
According to Fallen, this is likely fallout from bug 794477.

When building Lightning on Thunderbird-Try with JavaScript-only changes, I got a compile error, see https://tbpl.mozilla.org/php/getParsedLog.php?id=15915536&tree=Thunderbird-Try :

Many of these kind:
c:\tools\msvs10\vc\include\xutility(3412) : warning C4273: 'std::moz_Xruntime_error' : inconsistent dll linkage

        e:\builds\moz2_slave\tb-try-c-cen-w32\build\objdir-tb\mozilla\dist\include\mozilla\msvc_raise_wrappers.h(30) : see previous definition of 'moz_Xruntime_error'

And then these:
e:/builds/moz2_slave/tb-try-c-cen-w32/build/calendar/base/src/calDateTime.cpp(636) : error C2660: 'js_DateIsValid' : function does not take 2 arguments

e:/builds/moz2_slave/tb-try-c-cen-w32/build/calendar/base/src/calDateTime.cpp(641) : error C2660: 'js_DateGetMsecSinceEpoch' : function does not take 2 arguments

e:/builds/moz2_slave/tb-try-c-cen-w32/build/calendar/base/src/calDateTime.cpp(641) : fatal error C1903: unable to recover from previous error(s); stopping compilation
Comment 1 Stefan Sitter 2012-10-08 05:17:30 PDT
It is caused by Bug 793076 that removed the second parameter from that functions with todays checkin.
Comment 2 Philipp Kewisch [:Fallen] 2012-10-08 05:18:52 PDT
Created attachment 669119 [details] [diff] [review]
Fix - v1

Looks like I was coding against an old version of the API, or I have no idea why it was compiling. I've just updated mozilla-central, did a full rebuild and with these changes it works.
Comment 3 Philipp Kewisch [:Fallen] 2012-10-08 05:19:54 PDT
(In reply to Stefan Sitter from comment #1)
> It is caused by Bug 793076 that removed the second parameter from that
> functions with todays checkin.
Ah ok, then I wasn't all wrong :-P Stefan, if you'd like to review this patch instead feel free to!
Comment 4 Philipp Kewisch [:Fallen] 2012-10-08 09:15:51 PDT
Pushed to comm-central changeset ae6b83c2a3c0

Note You need to log in before you can comment on or make changes to this bug.