Failure to determine geolocation on ESR builds on every other try

RESOLVED WONTFIX

Status

()

Core
Geolocation
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: Ioana (away), Unassigned)

Tracking

10 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Mozilla/5.0 (X11; Linux i686; rv:10.0.8) Gecko/20100101 Firefox/10.0.8

STR:
1. Go to http://mozqa.com/data/firefox/geolocation/position.html.
2. When prompted to share location, select "always" (Or select "Share" and re-select it at step 3).
3. Reload the page.

Expected:
The latitude and longitude for your current geographic location is displayed on the web page.

Actual:
"undefined" is displayed on the page.

Notes:
1. Reproducible on Windows and Mac platforms too.
2. This bug is a clone of bug 716127. The bug was fixed on standard builds, ergo it doesn't reproduce on beta, release, aurora and nightly. It only reproduces on ESR builds.
possible root cause bug 804129?

Comment 2

6 years ago
Ioana, is this just a patch that didn't make the ESR build?  That is to say, it was fixed after the ESR branched away from mozilla-central?
Ioana, can you please check if this is reproducible in the latest esr10 and esr17 builds? I would expect if comment 2 is correct that this bug exists in 10 and not in 17. If that is correct, this is likely wontfix since 10.0.12esr is our last esr10 release.
Keywords: qawanted
QA Contact: ioana.budnar
(Reporter)

Comment 4

5 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #3)
> Ioana, can you please check if this is reproducible in the latest esr10 and
> esr17 builds? I would expect if comment 2 is correct that this bug exists in
> 10 and not in 17. If that is correct, this is likely wontfix since
> 10.0.12esr is our last esr10 release.

I couldn't reproduce it at all on 17.0.2ESR, and it only reproduces intermittently on 10.0.12ESR.
Keywords: qawanted
(Reporter)

Updated

5 years ago
tracking-firefox-esr10: --- → ?
Thank you Ioana. I'm going to mark this WONTFIX because we have no intention to release another Firefox 10esr unless there is a security chemspill, and this bug would not qualify for such a release. 

Anyone who is experiencing this bug and sees it as critical is advised to migrate to the 17esr branch.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-firefox-esr10: ? → ---
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.