Closed Bug 799120 Opened 12 years ago Closed 5 years ago

Show only the connected devices in Send Tab To Device list

Categories

(Firefox for Android Graveyard :: Android Sync, defect, P5)

ARM
Android
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: andreea.pod, Unassigned)

References

Details

(Whiteboard: [sync:tabs][sendtab])

Attachments

(1 file)

Attached image send tab to device list
Build: Firefox 16 (2012-10-06)
Device: Samsung Galaxy Nexus
OS: Android 4.1.1

Steps to reproduce:
1. Connect to a sync account with few Firefox profiles (delete the profile or clear it and then connect again)
2. try to share a tab and use Firefox Sync
3. Open Send Tab To Device

Expected result:
- only the profiles that are connected to sync should appear

Actual result:
- the list with the available profiles to which you can send the tab also contains the old profiles that are no longer available, so if you send a tab to one of that profiles it will never be received. Since you don't know which profile is the profile to which you want to send the tab you are forced to check all the profiles matching the wanted profile. As you can see in the screenshot, "Firefox Beta on Galaxy Nexus" appears 5 times in view and lot more if I pan the list.
You're a very unusual user, in that you're generating lots of client records ("client" is the term here, rather than "profile") as you test devices. The vast majority of users will never see this.

When you uninstall Firefox on Android, we have no way of removing our client record from the Sync server. That means you need to wait three weeks for it to expire.

In Firefox 18, Bug 770785 will allow you to remove the account before uninstalling to avoid these records sticking around, but still if you just uninstall Firefox the client record will remain as a zombie.

The best we can do here is to process on the phone -- order the list of clients by age, and perhaps visually bias against the oldest.
Marking this as P3, because we'll want to track it, but it's not a concrete work item.
Depends on: 770785, 821532
Priority: -- → P3
Whiteboard: [sync:tabs][sendtab]
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
IIUC the situation here is improved now that we use FxA for device management, can this be closed?
Flags: needinfo?(gkruglov)
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P3 → P5

Closing due to lack of further activity.

Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(gkruglov)
Resolution: --- → FIXED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: