Status

Firefox OS
Gaia::Calendar
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: lightsofapollo, Assigned: lightsofapollo)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [mentor=jlal@mozilla.com][LOE:S])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Display sync indicator when sync is in progress. The indicator should be one defined in BB. 

Steps:

look at controllers/sync.js (for more details)

- in (views/time_header.js probably?) listen to sync start events
- show an element with indicator, non-determinate is probably fine.
- hide the element on 'sync complete' event.'

This should be very simple and is also a good first bug
(Assignee)

Updated

5 years ago
blocking-basecamp: --- → ?
(Assignee)

Comment 1

5 years ago
More context here, the process of expanding a recurring event is CPU intensive (we need to expand all events from the beginning currently). That happens in a worker so the impact on the user is minimal but it results in a period where the sync seems to "fail" because no events are showing up or have a busytime in the month view but no event in the day view.

We need to make it clear that during that period we are "working" otherwise it looks like an error.
Priority: -- → P1
blocking-basecamp: ? → -

Comment 2

5 years ago
This is critical or the user will have no idea if syncing/progress is happening.  Marking as blocking.
blocking-basecamp: - → +
(Assignee)

Comment 3

5 years ago
Casey, can you help me define the intended behavior? The groundwork is done the rest should be a very simple addition of some css or image.
Flags: needinfo?(kyee)
(Assignee)

Comment 4

5 years ago
Created attachment 670722 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5787

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #670722 - Flags: review?(mbudzynski)

Comment 5

5 years ago
As per my IRC discussion with :lightofapollo.  We will adopt the same indeterminate load bar from the media apps.
Flags: needinfo?(kyee)
Assignee: nobody → jlal
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Keywords: verifyme
QA Contact: jsmith
Verified. When I do a sync with an imported calendar, I will get a sense of progress from the load bar in the main calendar.
Status: RESOLVED → VERIFIED

Updated

5 years ago
Keywords: verifyme
Attachment #670722 - Flags: review?(mbudzynski)
You need to log in before you can comment on or make changes to this bug.