Lightning does not appear to fall back to IMip when inviting people on a non-calendar-auto-schedule server.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: evert, Unassigned)

Tracking

Lightning 1.7

Details

(Whiteboard: [calconnect31])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121002073616

Steps to reproduce:

The fruux (https://fruux.com/) does not support calendar-auto-schedule.

In these cases lightning _should_ fall back to IMip (email) to send invitations for email.




Actual results:

Nothing happened. Nobody is invited :)


Expected results:

Lightning should have used IMip to handle the invitations.

Let me know if I can provide any detail or logs!
(Reporter)

Comment 1

6 years ago
These are the log messages (From the console) that happened during creation of the event:

CalDAV: itemUri.spec = https://dav-staging.fruux.com/calendars/1/A4F38959-F875-46EA-BF68-DCBC54862CC6/3f0a955e-c898-7b40-a759-d238a4055a49.ics
CalDAV: Item added to Test Calendar successfully
aChangeLogListener=undefined
calendarURI=https://dav-staging.fruux.com/calendars/1/A4F38959-F875-46EA-BF68-DCBC54862CC6/ 
iscached=true
this.mQueuedQueries.length=0
[calFilterProperties] Applying filter:
  start: 4
  end: P7D
  status: null
  due: null
  category: null
2012-10-08 18:42:24	gloda.NS	WARN	new proc ignoring attrib: id
Is caching enabled on the calendar? In this case it might be the same as in Bug 788004. Do you get any error message when creating the invitation?
Whiteboard: [calconnect31]
Lets talk about this tomorrow, I'd like to figure out exactly what we are not implementing. I thought we send email in this case.
Duplicate of this bug: 938536
We support sending emails if the server doesn't advertise calendar-auto-schedule, it must have been something temporary. Closing as discussed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.