Closed Bug 799221 Opened 7 years ago Closed 7 years ago

Turn off the marketplace as an app for now

Categories

(Firefox for Android :: Web Apps (PWAs), defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 19
Tracking Status
firefox17 --- verified
firefox18 --- verified
firefox19 --- verified

People

(Reporter: wesj, Assigned: wesj)

Details

(Whiteboard: [blocking-webrtandroid1+])

Attachments

(1 file)

No description provided.
Note this isn't meant to prevent doing this entirely, just to remove the special code in our UI that prompts the user for it and adds special abilities to it (i.e. the Manifest entry and the Helper Apps bits) There's also some special code to NOT prompt for the install if the app is the marketplace app that should go disabled.
Attached patch PatchSplinter Review
Disable the helperapps stuff, manifest stuff, and no-prompt install.
Attachment #669288 - Flags: review?(mark.finkle)
Comment on attachment 669288 [details] [diff] [review]
Patch

This will do enough to "turn off" the ability to run the Marketplace as an app. It does not remove all the code it could. I am just wondering how much we should keep.

As a patch that might need uplift to Beta, this would be low risk enough though.
Attachment #669288 - Flags: review?(mark.finkle) → review+
FYI - Please hold landing this. See the email thread for context.
Is this inteded for mozilla-beta for now, or across the entire board?
OS: Windows 7 → Android
Hardware: x86_64 → ARM
(In reply to Aaron Train [:aaronmt] from comment #7)
> Is this inteded for mozilla-beta for now, or across the entire board?

Across the board, and we could refactor as needed on m-c and m-a
Got this concern addressed on the go/no go call. Go ahead and land this. Sorry for the confusion.
Flagging as a blocker given what the plan is for v1 with webrt on android.
Whiteboard: [blocking-webrtandroid1+]
Comment on attachment 669288 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 778913
User impact if declined: There are a few bugs with the interaction of the marketplace as an app idea that haven't been fixed yet.
Testing completed (on m-c, etc.): Landed on mc today
Risk to taking this patch (and alternatives if risky): Low risk. Just disables code that should only affect the marketplace webapp.
String or UUID changes made by this patch: None.
Attachment #669288 - Flags: approval-mozilla-beta?
Attachment #669288 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ab420f694c83
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Status: RESOLVED → VERIFIED
Attachment #669288 - Flags: approval-mozilla-beta?
Attachment #669288 - Flags: approval-mozilla-beta+
Attachment #669288 - Flags: approval-mozilla-aurora?
Attachment #669288 - Flags: approval-mozilla-aurora+
QA Note: Old behaviour on 17.0b1
Whiteboard: [blocking-webrtandroid1+] → [blocking-webrtandroid1+], [needs-beta-uplift], [needs-aurora-uplift]
Whiteboard: [blocking-webrtandroid1+], [needs-beta-uplift], [needs-aurora-uplift] → [blocking-webrtandroid1+], [needs-beta-uplift]
Someone needs to land this to beta branch asap - who triages the [needs-beta-uplift] tag?
Is this still desirable on Beta given we have no easy access UI to about:apps?
(In reply to Aaron Train [:aaronmt] from comment #17)
> Is this still desirable on Beta given we have no easy access UI to
> about:apps?

Possibly. Remember that users can still go to marketplace.mozilla.org from fennec beta. If they do, they'll get the marketplace as an app, which will introduce the known papercuts and other issues we talked about. I'd just get this turned off.
Whiteboard: [blocking-webrtandroid1+], [needs-beta-uplift] → [blocking-webrtandroid1+]
If I go to marketplace.mozilla.org, nothing happens on the latest Beta build. Changing the firefox 17 flag to verified.

--
Firefox 17.0b6 (2012-11-13)
Device: Samsung Galaxy S2
OS: Android 4.0.3
Verified on:
Build: 18.0 (2012-11-19) Aurora Channel
Device: Samsung  Galaxy R
OS: Android 2.3.4
You need to log in before you can comment on or make changes to this bug.