cannot file bugs on bugzilla from metro, assertion in nsHTMLInputElement.cpp: You should not call GetFileFiltersFromAccept if the element has no accept attribute!

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: ally, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 669274 [details]
assertion preceding the crash

STR:
1)run metro (in my case on a win7 box)
2) go to bugzilla
3) 'file a bug'
4) 'Firefox'
5) run into assertion {abort, retry, ignore} all result in a crash (since text wont cp/paste out of the modal dialog, attached as image) in nsHTMLInputElement.cpp ln 4778
You are trying to run the metro build on a win7 system ?
I don't know if that is supported.

Do you have a stacktrace/crash ID for the following crash ?
Component: Untriaged → General
Product: Firefox → Core
Metro on Win7 is used for development purposes, so we should try to fix this bug if even if it only happens there.  I wasn't able reproduce this crash in either Windows 8 or Windows 7, using a local opt build.  It might happen in debug builds only.
Summary: cannot file bugs on bugzilla from metro, fatal error in nsHTMLInputElement.cpp → cannot file bugs on bugzilla from metro, assertion in nsHTMLInputElement.cpp: You should not call GetFileFiltersFromAccept if the element has no accept attribute!
I think it was just an assertion, not a crash.
(Reporter)

Comment 4

6 years ago
it asserted, then crashed

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.