Closing tabs by accident because the close icon is not visible

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: amartya, Unassigned)

Tracking

15 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 669319 [details]
Screen Shot 2012-10-08 at 5.41.13 PM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I clicked on a tab among the 10 tabs I had open on my Macbook Pro 13" running Firefox 15.0.1.


Actual results:

It closed the tab instead of selecting it. The reason is quite simple. I clicked on the right hand side of the tab and it was where the "close" icon (or X symbol) usually is. Only, this time it wasn't visible because I had more than 8 tabs open. But apparently the button was still active though invisible(has a onClick handler?).

This is more a usability bug, but Chrome seems to handle this more gracefully. So once you have enough tabs open such that the X icon takes up more space than you can spare, one needs to first select a tab, and only then the X become visible for you to click and close that tab.


Expected results:

The tab should have been selected rather than closing it.

Comment 1

6 years ago
Can you reproduce it?  Maybe you’ve double-clicked the tab?
Component: Untriaged → Tabbed Browser

Comment 2

6 years ago
WFM on the 10/15 Nightly.

amartya@outlook.com, can you reproduce this issue with a clean profile?
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(amartya)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

6 years ago
Works for me now (started with a clean profile). Thanks and apologies for the delayed response.
Flags: needinfo?(amartya)
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.