From: dropdown list has no effect on LDAP autocomplete settings

VERIFIED FIXED in mozilla0.9.2

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Hong Kwon, Assigned: Srilatha Moturi)

Tracking

Trunk
mozilla0.9.2
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+], have a fix, r=, sr=, patch in 79792)

(Reporter)

Description

17 years ago
If a user has specified per-account LDAP autocomplete settings, and invokes a 
composition window and changes their identity using the From: dropdown list, 
their per-account settings aren't correctly propagated.  The settings at time of 
composition invocation will be used. 

To reproduce, you need two different mail accounts with different autocomplete 
settings.

Steps to reproduce:
1. Specify a global autocomplete server in prefs.
2. Override autocomplete for test account 1 and set to "None".
3. In Messenger, click on test account 2 in the folder pane.
4. Click on New Msg.
5. In the New Msg window, change the From: dropdown list to test account 1.
6. Type in a name.

Expected Results

No autocompletion occurs.

Actual Results

Autocompletion occurs.  Autocomplete preferences for the account should be 
propagated when the From: dropdown list is changed.
(Reporter)

Updated

17 years ago
QA Contact: esther → yulian
(Reporter)

Updated

17 years ago
Keywords: nsbeta1
(Reporter)

Updated

17 years ago
Keywords: nsbeta1
(Assignee)

Updated

17 years ago
Priority: -- → P2
Target Milestone: --- → mozilla0.9.2

Comment 1

17 years ago
See also bug 82169.
Priority: P2 → P3

Comment 2

17 years ago
PDT+ per 6/12 mtg.
Whiteboard: [PDT+]
(Assignee)

Comment 3

17 years ago
when autocompleting with test account2, we have both AbAutocompleteSession and 
LDAPAutocompleteSession.
when autocompleting with test account 1, we should have only 
AbAutocompleteSession but we have both AB and LDAP sessions even though we are 
not calling getService on the LDAPAutocompletSession. Looks like the sessions 
list is not getting updated.
ccing ducarroz and hewitt.
(Assignee)

Updated

17 years ago
Blocks: 79792
(Assignee)

Updated

17 years ago
Blocks: 80783
(Assignee)

Updated

17 years ago
Depends on: 86425

Updated

17 years ago
Depends on: 84577

Updated

17 years ago
No longer depends on: 86425
(Assignee)

Comment 4

17 years ago
the patch in 79792 will fix this
Whiteboard: [PDT+] → [PDT+], have a fix, r=, sr=, patch in 79792
(Assignee)

Comment 5

17 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Verified with 2001062204 trunk builds on all platforms
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.