If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: On parental leave, Assigned: rik)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Bug 793186 is already landed in m-c so we should probably rename each USSD mention in Gaia to MMI.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 798832
Sorry didn't understood this correctly. Can we list the changes left to be clearer?

* Rename ussd.js to mmi.js
* Rename ussd_ui.js to mmi_ui.js

Anything else?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

5 years ago
(In reply to Etienne Segonzac (:etienne) from comment #2)
> Sorry didn't understood this correctly. Can we list the changes left to be
> clearer?
> 
> * Rename ussd.js to mmi.js
> * Rename ussd_ui.js to mmi_ui.js
> 
> Anything else?

Yes, basically we should rename each mention of USSD to MMI, except for the ussdreceived event, which is still fired by the platform. The rest should be renamed to MMI, since the MMI functionality is what is exposed to the DOM and includes the USSD one.
Please, take into consideration that there is at least one PR on the fly with changes on those files (ussd.js and ussd_ui.js) which may be merged (after revision) before renaming them ;-) Thanks!
Sorry, I forgot to add the PR link: https://github.com/mozilla-b2g/gaia/pull/5728

Updated

5 years ago
Component: Gaia → Gaia::Dialer
(Reporter)

Updated

5 years ago
Blocks: 796657
Assignee: nobody → gtorodelvalle
(Assignee)

Comment 6

5 years ago
The pull request in bug 853798 handles this renaming.
Assignee: gtorodelvalle → anthony
Depends on: 853798
(Assignee)

Comment 7

5 years ago
Bug 853798 has landed everywhere, closing!
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.