Closed Bug 799469 Opened 8 years ago Closed 8 years ago

pac file alert() broken

Categories

(Core :: Networking: HTTP, defect)

18 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox17 --- unaffected
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: mcmanus, Assigned: mcmanus)

References

Details

Attachments

(1 file)

in bug 795597 matti provides this pac file that isn't working for two reasons.

function FindProxyForURL(url, host){

if (isResolvable("nonexistant.lan"))
    
{
return "DIRECT";
}

else {
alert(myIpAddress()); 
return "SOCKS5 127.0.0.1:8080";
}
}

the 769764 rewrite of pac file handling implemented proxyAlert() instead of alert(). alert() should be defined but proxyAlert() should not be for backwards compatibility.
Attached patch patch 0Splinter Review
Assignee: nobody → mcmanus
Status: NEW → ASSIGNED
Attachment #669607 - Flags: review?(cbiesinger)
Comment on attachment 669607 [details] [diff] [review]
patch 0

heh oops. sorry for not catching that in the review
Attachment #669607 - Flags: review?(cbiesinger) → review+
Comment on attachment 669607 [details] [diff] [review]
patch 0

[Approval Request Comment]
Bug caused by (feature/regressing bug #): jank killing proxy rewrite 769764
User impact if declined: pac files using diag function alert() will fail to operate
Testing completed (on m-c, etc.): manual
Risk to taking this patch (and alternatives if risky): very low risk.. it just changes a function name from proxyAlert to alert to maintain backwards compat
String or UUID changes made by this patch:  none
Attachment #669607 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/cb9aa35ad1ca

Should this have a test?
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
(In reply to Patrick McManus [:mcmanus] from comment #4)
> Comment on attachment 669607 [details] [diff] [review]
> patch 0
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): jank killing proxy rewrite 769764
> User impact if declined: pac files using diag function alert() will fail to
> operate

What's a pac file and who uses them.
(In reply to Alex Keybl [:akeybl] from comment #6)
>
> 
> What's a pac file and who uses them.


pac - proxy auto config

http://en.wikipedia.org/wiki/Proxy_auto-config

Amongst proxy users, its a pretty common way of defining the proxy and when to use it. Our default windows configuration will use it if the LAN administrator has set things up that way.
Attachment #669607 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.