AMO reviewers should not be identified as reviewer installs on Marketplace

RESOLVED FIXED in 2012-10-11

Status

Marketplace
Consumer Pages
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Optimizer, Assigned: cvan)

Tracking

2012-10-11
x86_64
Windows 7
Points:
---

Details

(Reporter)

Description

5 years ago
I don;t know if it is an Windows 7 only issue or not.
I am using Windows 7, latest Nightly and I have add-on editor privileges.

I click on the Free button of any app, and it won't install, no door hanger appears.

Webconsole shows that the POST call resulted in a 403 forbidden (for Twitter)

[19:38:09.550] POST https://marketplace.mozilla.org/reviewers/receipt/issue/twitter?src=mkt-home [HTTP/1.1 403 FORBIDDEN 650ms]
(Assignee)

Comment 1

5 years ago
Are you trying to install the app from https://marketplace.mozilla.org/reviewers/apps/review/twitter or https://marketplace.mozilla.org/apps/twitter ?

I don't get an error on either. What's your username?
(In reply to Chris Van Wiemeersch [:cvan] from comment #1)
> Are you trying to install the app from
> https://marketplace.mozilla.org/reviewers/apps/review/twitter or
> https://marketplace.mozilla.org/apps/twitter ?
> 
> I don't get an error on either. What's your username?

He was trying https://marketplace.mozilla.org/apps/twitter - he doesn't have app reviewer access.  His email is the same one used on bugzilla.

I don't get the error either but we probably both have different access than Girish.
(Assignee)

Comment 3

5 years ago
As a whitelisted user with no special privileges, I can also install this app without problems: http://f.cl.ly/items/190k2N0u3k2U2u2L281t/Screen%20shot%202012-10-09%20at%208.41.30%20AM.png

Only if you're the author of the app or if you're reviewing it from the Reviewer Tools should we POSTing to /reviewers/recipe/issue/<app>. I wish I could reproduce - this is awfully suspicious.
(Reporter)

Comment 4

5 years ago
Its not just twitter, but any app I try to install has the same result.

I just click on the "Free" button that is available on the app's page.

Comment 5

5 years ago
Hey Girish,

Looks like you have access to do Add-on Reviews but not for Apps. Can you see if you have the problem if

a) you are on a new Firefox profile?
b) a new marketplace account?

Thanks,
Krupa
(Assignee)

Updated

5 years ago
Assignee: nobody → cvan
Summary: Nothing happens when you try to install a web app from Mozilla marketplace. → AMO reviewers should not be identified as reviewer installs on Marketplace
Target Milestone: --- → 2012-10-11
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla/zamboni/commit/ae4d4eb
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.