Closed Bug 799492 Opened 7 years ago Closed 7 years ago

Update Settings string for text reflow

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 19
Tracking Status
firefox18 - ---
firefox19 --- verified

People

(Reporter: ibarlow, Assigned: jwir3)

References

Details

Attachments

(1 file, 1 obsolete file)

The current string in Settings reads: "Enable Reflow-On-Zoom", which is a little more technical sounding than we probably want, and is also set in title case when it should be sentence case. 

Let's update the menu item, a couple of options for how we might change it are included here.


Option 1 
-----------------------------------
Page layout  
[ Normal / Pinch to reflow text ] 


Option 2
-----------------------------------
Pinch to reflow text         [ ]
OS: Mac OS X → All
Hardware: x86 → All
How about "Wrap text within view"?
Hm, I'm not sure that "within a view" is a concept most users would understand, to be honest...
Attached patch b799492 (obsolete) — Splinter Review
Assignee: nobody → sjohnson
Status: NEW → ASSIGNED
Attachment #670866 - Flags: review?(blassey.bugs)
Attachment #670866 - Flags: review?(ibarlow)
Attachment #670866 - Flags: review?(blassey.bugs) → review+
Attachment #670866 - Flags: review?(ibarlow)
Inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9cf34ca3d81c
Target Milestone: --- → Firefox 19
Attached patch Rollup patchSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): reflow-zoom
User impact if declined: Less intuitive user-visible preference for enabling reflow-on-zoom.
Testing completed (on m-c, etc.): Currently on m-c 
Risk to taking this patch (and alternatives if risky): Very low risk, but there are string changes. 
String or UUID changes made by this patch: String change to a user-visible preference (android_strings.dtd).

I forgot to change the string identifier when I made this change. This was made in a followup patch, which has been rolled into this patch now to be pushed to aurora.
Attachment #670866 - Attachment is obsolete: true
Attachment #671548 - Flags: approval-mozilla-aurora?
Aurora Drivers: We'd really like to fix this string. We should have caught it in m-c, but missed it.
(In reply to Mark Finkle (:mfinkle) from comment #7)
> Aurora Drivers: We'd really like to fix this string. We should have caught
> it in m-c, but missed it.

If product sees this as a requirement for the feature, please send a courtesy email to dev-l10n, and we'll uplift once they've been notified.
Build ID: 19.0 (2012-10-16) Nightly Channel
Device: Samsung Galaxy Nexus
OS: Android 4.1

Now in settings is Pinch to reflow text, second proposal. Bug Verified for Nightly . 

Still present in Build ID: 18.0a2 (2012-10-16) Aurora Channel. It's is flagged for Aurora too?
"Pinch to reflow text" or "Reflow text on zoom" would get my vote.

Neither is great, but either is better than "Enable Reflow-On-Zoom"
Alex - I sent a heads up to dev-l10n
(In reply to Madhava Enros [:madhava] from comment #11)
> "Pinch to reflow text" or "Reflow text on zoom" would get my vote.
> 
> Neither is great, but either is better than "Enable Reflow-On-Zoom"

I think the problem here is that users don't understand what "reflow" might mean.  That's a pretty technical term that has meaning if you've been working in layout code, but outside of that group I think it won't mean much.

Isn't this just about enabling "pinch to zoom."    I think the focus should be on what the users does, and what the users see, in terms that a common user might see.

 The wording here really ought to get some user testing.  I'm not sure what we get out of changing from one not understandable term to another, and I really don't see the need to uplift until we get something that pretty good and understandable.
I suspect a term like "re-wrap" or even "reformat" might be more readily understandable than "reflow". E.g.,
  Re-wrap text lines on zoom  [ ]
or
  Reformat text on zoom  [ ]

But that's just a personal hunch - certainly not user-tested!
I think users understand what zoom is, and that zoom should "just work as expected" in their mental model of zooming; so its the re-wrapping, reformating, or re-anything that will cause the confusion.
There's zooming when you double tap, and zooming when you pinch.  It looks like this setting only affects the latter?

"Pinch to reflow text" suggests, IMO, that the primary goal of pinching is the text reflow, and not zooming.  Could this be confusing?

After more testing of this feature, I'd suggest one of the following:

  A) Always wrap text on zoom
  B) Wrap text when pinching

I'd go with A) because 'pinch' is a recent word in the vocabulary of the UI actions and might not have good (and short!) translations yet.
(In reply to chris hofmann from comment #15)
> I think users understand what zoom is, and that zoom should "just work as
> expected" in their mental model of zooming; so its the re-wrapping,
> reformating, or re-anything that will cause the confusion.

FWIW - I agree here. The main strength, in my opinion, of our strategy around font inflation so far has been that it's invisible. Test is just more readable without having to make any choices, or choose your technique. My preference would be to use reflow automatically and selectively in particular cases where we can tell that inflation is insufficient.
We're waiting for consensus between engineering/UX/l10n before moving forward with a string change here.
(In reply to Alex Keybl [:akeybl] from comment #18)
> We're waiting for consensus between engineering/UX/l10n before moving
> forward with a string change here.

Turns out, I no longer really care. Beta will ever see this preference as is, we'll remove it after merge. I'll add that to the Wiki for post-merge backouts.

Carry on, nothing to see here.
Attachment #671548 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
(In reply to Mark Finkle (:mfinkle) from comment #20)
> Added note here:
> https://wiki.mozilla.org/Release_Management/
> Merge_Documentation#Known_Backouts_for_Version

So this bug isn't actually the bug that will need to be backed out, I don't think. Backing out bug 799492 will change the settings string back to "Enable Reflow On Zoom", which is not in aurora right now. (That is to say, this bug, bug 799492, will not go into beta until FF 19 goes into beta). Is that what we're looking to do, or are we looking to remove the settings string altogether from beta after the merge?
This string is really hard for localizers to handle.  Both 'pinch' and 'reflow' are words which possibly don't have one-word equivalents in some languages.   If the decision is to remove this string (I'm not sure I understand comment 19 well), please remove it from aurora too, and notify the dev-l10n that they *don't have* to localize this.
mfinkle - can you help with comment 21?
Flags: needinfo?(mark.finkle)
(In reply to Alex Keybl [:akeybl] from comment #23)
> mfinkle - can you help with comment 21?

Bug 803630 is the one we care about for Aurora. This bug is done... for now. File a new bug if we need a new string.
Flags: needinfo?(mark.finkle)
Strings were updated on the latest Nightly: "Pinch to reflow text". Closing bug as verified fixed on:

Firefox 19.0a1 (2012-10-29)
Device: Galaxy R
OS: Android 2.3.4
Status: RESOLVED → VERIFIED
Not tracking as per comment 24
You need to log in before you can comment on or make changes to this bug.