automate symlink creation for beta and esr releases

RESOLVED DUPLICATE of bug 785965

Status

Release Engineering
Release Automation: Other
RESOLVED DUPLICATE of bug 785965
6 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
We just added symlink updating automation over in bug 785965. QA would like symlinks to be maintained for ESRs and Betas, so they can have static download links for their automation. It shouldn't be simple to enable the same automation for these.
(Assignee)

Updated

6 years ago
Assignee: nobody → bhearsum
Created attachment 671968 [details] [diff] [review]
tools

configs incoming
Attachment #671968 - Flags: review?(bhearsum)
Attachment #671972 - Flags: review? → review?(bhearsum)
Looking at the attached patches, would it be possible to include a 'latest-esr' instead (or in addition to) 'latest-10.0esr'? The reason is, having the version number will incur a maintenance cost, even if it is once a year or so.
(Assignee)

Comment 4

6 years ago
I don't want to add a manual step here - that's exactly what we're trying to get rid of. How about we set mozilla-esr10 to symlink to 'latest-esr' for now, and then when we ship the first esr17 we'll set it up to symlink to 'latest-esr', and esr10 to symlink to either nowhere or 'latest-esr10'.
(In reply to Ben Hearsum [:bhearsum] from comment #4)
> I don't want to add a manual step here - that's exactly what we're trying to
> get rid of. How about we set mozilla-esr10 to symlink to 'latest-esr' for
> now, and then when we ship the first esr17 we'll set it up to symlink to
> 'latest-esr', and esr10 to symlink to either nowhere or 'latest-esr10'.

Sounds good to me.
Comment on attachment 671968 [details] [diff] [review]
tools

Incorporated into bug 785965
Attachment #671968 - Flags: review?(bhearsum)
Comment on attachment 671972 [details] [diff] [review]
configs

Incorporated into bug 785965
Attachment #671972 - Flags: review?(bhearsum)
(Assignee)

Comment 8

6 years ago
This is getting fixed is a roll-up patch in bug 785965
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785965
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.