dmADB error creating directory in constructor with B2G emulators

RESOLVED DUPLICATE of bug 799288

Status

RESOLVED DUPLICATE of bug 799288
6 years ago
6 years ago

People

(Reporter: ahal, Assigned: ahal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
This is an error that was exposed by https://github.com/mozilla/mozbase/commit/f2cfb5e1ee6dc50449d222da1246ca1e39bfac14

In dmADB's _setupDeviceRoot we create the device root at either /mnt/sdcard by default, but this can be overridden if by creating a /data/local/tests directory.

In B2G emulators, /mnt/sdcard is read-only and creating the directory fails. Previous to having exceptions this would fail silently and dmADB would automatically fall back to /data/local. However now an uncaught exception gets raised.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799288
You need to log in before you can comment on or make changes to this bug.