bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Version specific and uninstall info moved to wrong place in registry

RESOLVED DUPLICATE of bug 789743

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 789743
6 years ago
6 years ago

People

(Reporter: Dave Oksner, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121005155445

Steps to reproduce:

Update to Mozilla Firefox 15.0.1; then update to 16.0


Actual results:

Registry Name CurrentVersion for Key "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Mozilla\Mozilla Firefox" never not get updated.  Suspect that it was created for key "HKEY_CURRENT_USER\Software\Mozilla\Mozilla Firefox" since that now has a full parallel-looking tree that appears to be appropriate for version 16.0.


Expected results:

Registry Name CurrentVersion for Key "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Mozilla\Mozilla Firefox" should have been updated with 15.0.1, then 16.0.
(Reporter)

Comment 1

6 years ago
As a note, this does NOT happen with Windows Servers 2008-R2.  Win 2k8-r2 continues to update the same area of the registry just like it always did.  Perhaps this was a bug introduced when trying to handle Windows 8.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789743
You need to log in before you can comment on or make changes to this bug.