Zimbra login page doesn't preselect "Mobile" when called with Firefox OS

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Robert Kaiser, Assigned: miketaylr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff] [contactready] [country-all], URL)

(Reporter)

Description

5 years ago
I guess that Zimbra is detecting "Android" in the UA instead of "Mobile" and therefore it's not recognizing Firefox OS as a mobile platform, i.e. not preselecting "Mobile" in the "Version" dropdown.
When selecting that one for login, it works pretty well there, though.

This can be seen by going to https://mail.mozilla.com/zimbra/ in the browser of a Firefox OS device.
Assignee: english-us → nobody
Component: English US → Mobile
(Reporter)

Updated

5 years ago
OS: All → Gonk

Comment 1

4 years ago
Confirmed. Firefox for Android is working. Firefox OS is getting the desktop environment.
Whiteboard: [serversniff] [contactready]
I filed this one a while back.

https://bugzilla.zimbra.com/show_bug.cgi?id=80575
Mike - AFAIK Zimbra's source code is open. Care to submit a patch?
Happy to give it a stab.
Assignee: nobody → miket
(Reporter)

Updated

4 years ago
Duplicate of this bug: 814351

Updated

4 years ago
Whiteboard: [serversniff] [contactready] → [serversniff] [contactready] [country-all]
Fixed over at https://bugzilla.zimbra.com/show_bug.cgi?id=80575.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.