microsoft.com - Page not rendering correctly

VERIFIED WONTFIX

Status

Tech Evangelism Graveyard
English US
P1
normal
VERIFIED WONTFIX
17 years ago
3 years ago

People

(Reporter: xtim, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
On the left hand-side of this page, there are pseudo menus which display with a
small + sign which can be openned when using MS IE, on Netscape these display as
expanded menus on Mozilla .9 these do not work using either method.

Comment 1

17 years ago
I'm sure we've sent a thousand evangelism messages to Microsoft already, anyone
want to send another?

Reporter: FYI, this page does "not work" in Mozilla because Microsoft uses
non-standard Object Models for their dynamic content. Mozilla only supports the
W3C standard Document Object Model (DOM) and therefore "fails" on sites that use
only proprietary Object Models.
Actually, in this case they _are_ using the W3C DOM...  All the submenus start
with display:none.  Then we have:

function tier1Menu(objMenu,objImage) {
    if (bDoesAll | bIsMac) {
        if (objMenu.style.display == "none") {
            objMenu.style.display = "";
            objImage.src = "/java/graphics/minus.gif";
        }
        else {
            objMenu.style.display = "none";
                        objImage.src = "/java/graphics/plus.gif";
        }
    }
}

and above that:

bDoesAll = (bIsIE4 || bIsIE5 || bIsIE6) && !bIsMac;

This would work just dandy in Mozilla if they would just update their bDoesAll
to reflect reality.

This is _so_ evangelism!
Assignee: rods → bclary
Status: UNCONFIRMED → NEW
Component: HTML Form Controls → Evangelism
Ever confirmed: true
OS: Linux → All
QA Contact: vladimire → zach
Hardware: Other → All
(Assignee)

Updated

17 years ago
Priority: -- → P1
(Assignee)

Updated

17 years ago
Summary: Page not rendering correctly → microsoft.com - Page not rendering correctly
(Assignee)

Comment 3

17 years ago
contacted 7/6/01 using their web feedback form. Marking assigned to indicate
they have been contacted.
Status: NEW → ASSIGNED
(Assignee)

Comment 4

17 years ago
I have contacted Microsoft concerning these problems however due to external
factors it is clear that Evangelism is not an appropriate method of contacting
them concerning problems with their content.

Marking WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 5

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 6

17 years ago
Verified per instructions at http://mozilla-evangelism.bclary.com/evangelism.html
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.