[Social API] Facebook Posts to help launch the social api

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Laura Forrest, Assigned: Ty Flanagan)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
More info coming soon.

Comment 1

6 years ago
Thanks - just FYI that copy/design bugs would tie into this so please be sure to file those asap and connect the bugs.
In progress here. Graphics will be needed once copy is finalized:
https://yummy.etherpad.mozilla.org/social-api-social-posts?

Launch post: Nov. 20
Facebook Messenger for Firefox is available starting today! Working with our friends at Facebook, we've made it easier to stay connected with your social circle no matter where you go on the Web. Make sure you're on the latest version of Firefox and then visit this Facebook tab to turn it on!
Graphic: Can we use the graphic that has the magnifying glass magnifying the Facebook jewels? We can crop in on that image in a 400x400

November 28 post
Are you as excited as we are about the Facebook Messenger for Firefox feature? It makes the whole Web social, and that's something to celebrate! Turn it on here: (tab link)
Graphic: Need something more Firefox-y from brand. Maybe it's an image with confetti, or something showing we're "excited"

December 8 post
This year, make your holiday shopping more social. Chat with your siblings while you select the perfect gift for Mom. Or watch your friend activities in real time for hints about what to get them. Facebook Messenger for Firefox lets you do all that - turn it on now! (tab link)

Dec. 19 post - photo of person in Firefox shirt with the computer?
TBD

December 27 post I'd like to use the blog post to promote social api here
TBD

Comment 3

6 years ago
hi there, what's the status here.... let me know how I can help wrt design (if at all)
The status is that we still need graphics. I'd tackle the first three posts firsts, while we work out the copy for the last two.

Comment 5

6 years ago
ok, that's a pretty clear status ;) 
I'm moving this over to the design component since we're discussing copy/design here. 

my thoughts inline: 

> Launch post: Nov. 20

> Graphic: Can we use the graphic that has the magnifying glass magnifying the
> Facebook jewels? We can crop in on that image in a 400x400

Yes, we're going to also wrap that with a "new" burst or ribbon to call it out more. It'll essentially be similar to the /features page graphic or smaller promos (like tabzilla). Assigning this to Matt. 

> 
> November 28 post

> Graphic: Need something more Firefox-y from brand. Maybe it's an image with
> confetti, or something showing we're "excited"

hmmm, this one is a little more challenging.  I think we may be able to create something that either pairs the FF logo and messenger icon in a "celebratory" way... or leaning more towards the chat bubble collage graphic that Ty started exploring - except I wouldn't want to design new icons that would deviate from the look and feel we've set for this campaign - nor would I want it to look like a new identity.  And I'd prefer to not use the Fox costume.... another option is a more text-oriented graphic (which would need to be localized) that has colorful bursts to dial up the excitement, while the text simply reinforces the feature.  I'll assign this one to Ty.  Lets discuss further. 


> 
> December 8 post
> This year, make your holiday shopping more social. Chat with your siblings
> while you select the perfect gift for Mom. Or watch your friend activities
> in real time for hints about what to get them. Facebook Messenger for
> Firefox lets you do all that - turn it on now! (tab link)

Does this not have a graphic? Just confirming. I don't think every single post needs a graphic... 

> 
> Dec. 19 post - photo of person in Firefox shirt with the computer?
> TBD
> 
> December 27 post I'd like to use the blog post to promote social api here
> TBD

I'll wait for more direction for the two above. 
The graphics also need to be approved by facebook.
Assignee: nobody → tyronflanagan

Updated

6 years ago
Component: Social Media → Design
Hey there, 

That direction sounds good. Every social post needs a graphic otherwise the engagement rate on it will tank. 

I'm not sure how to tie in the holiday shopping, but we'll need something to put in there.

Comment 7

6 years ago
Sounds good - though I think we should also weigh the pros and cons of forcing a graphic in there vs. having a lean update w/out one.  My concern is that we don't have a lot to work with here and I don't want to put something in there that's sub-par just to have a graphic - I don't think that will necessarily help engagement rate (or the brand).  Perhaps we can see if new illustrations make sense - but that changes scope and needs more discussion... so something to keep in mind.  Since we ordered that hat, we could also look into using that in some creative way to extend the identity through updated screenshots or photographs.
I think it would be wise to go with the recommendations of our social media experts here. They know the audience and they know how to make sure that the post has a high engagement rate (a high engagement rate means that the post will show up in more feeds - a low engagement rate means that Facebook's post algorithm will eat us for lunch). We have high hopes for this feature which means we should be giving every promotion that ends up in our Facebook feed the best possible chance at success. 

If we go without an image it would drastically slice into the number of people who will get the message. It would be like going from thousands of likes/engagements to hundreds. Even a sub-par graphic would be better than no graphic at all. 

I love the idea of working in the fox hat. It also gives us the chance to work in a cute child in said hat. Kids in hats get lots of likes. If you could put a cat in that hat, you'd win the Internet.

Comment 9

6 years ago
Thanks Chelsea, I understand the goals and need to generate as much engagement with each post as possible... I'm just saying that when it comes down to it we'll need to weigh the pros and cons and evaluate whether throwing in just *any* graphic for the heck of having one is the best solution or if we should come up with something else.  

This feature doesn't have much in terms of a visual identity, and what we have doesn't translate well in small spaces - and it's not easy to slice it differently for unique posts.  So we'll need to figure out what makes sense here - even if it means showing the same graphic twice, perhaps with a different color - or coming up with a creative way to incorporate the hat. But whatever the solution is it should fit in with the overall look and feel of the campaign we've designed, have the highest quality possible and be aligned with the brand - and approved by fb of course.  So a lot of factors.  

The social API post for example doesn't have any graphics associated with it.  I can offer a graphic with text only (which is what we've done for MDN) but there are some updates that may not easily translate into a graphic.  

Please be sure to update the list above with the copy as soon as possible.  I'll focus on the first 2 for now, and we'll figure out the other ones as they come.

Comment 10

6 years ago
Created attachment 681780 [details]
FB_post_400x400
This one is definitely tricky. Engagement on Facebook is complicated and what works there is different than works in other channels (and often surprises me). If images have higher engagement rates, I think we should consider using them where possible, even if they don't necessarily line up with what we're doing in other media. That doesn't mean just slapping any old thing on there, but it might be worth exploring other options here.

I'm also adding Carmen and Winston to get there thoughts.

Comment 12

6 years ago
Hey all, happy to chime in. Many of Chelsea's comments came from joint convos, so I think she's on target. :)

I've been working with Chelsea and William to develop the text above, so I think we're good on that. 

However, I would stress +1000 on using graphics each time (but we don't want to repeat the graphics.) A post without a graphic would get maybe 2-300 engagements. A post with a graphic usually performs in the thousands. If we have a goal of 6 million users of this feature, it's really a waste of a Facebook post if we don't maximize engagement. (Also note, each poorly performing post hurts FUTURE posts as well.)

As we move forward with promotion, I would recommend we focus less on the Facebook messenger icon (we'll push that in the beginning) but we're going to have to take the direction a little less formal (I'm thinking we'll be promoting this for months.)

We don't have to use the Fox costume photos, but we should start moving towards photos of people using the feature - they are what we use to promote all of our products. 

My only concern is a concern Tara mentioned in another email - this is the Firefox Facebook page. Not the Facebook Facebook page. :) I just want the graphics to feel Fox-y :)

Comment 13

6 years ago
Also, I'm not sure if this was the bug I needed to clarify this in, but the FB graphic is 403x403 px

Comment 14

6 years ago
(In reply to Carmen from comment #12)

> 
> My only concern is a concern Tara mentioned in another email - this is the
> Firefox Facebook page. Not the Facebook Facebook page. :) I just want the
> graphics to feel Fox-y :)


Duly  noted.  no worries.  

--------

Hi all

We seem to have had a few bugs overlapping here, asking for similar content.  I'm going to share a single link for download graphics for facebook, it includes:

* variations with copy, and without.
* variations on the two sizes you've specified.
* you can choose which asset fits your needs.

Those assets are here:
http://cl.ly/3O2L1J1q1c3M

This will suffice for the first post requested above - and possibly the second.  
Please use these graphics for the launch related posts.
Assignee: tyronflanagan → ltom

Updated

6 years ago
Status: NEW → ASSIGNED
Hey Tara, 

I know everything is pretty slammed with Flicks and MWC coming up, so I wanted to ping you about this now. We've got the graphic locked down for the first post - thank you for posting all of that. 

We'd like to request a graphic for the follow up post. I know we have variants of the hero image, but is there something else we can do for the follow up.

The copy is: 
Are you as excited as we are about the Facebook Messenger for Firefox feature? It makes the whole Web social, and that's something to celebrate! Turn it on here: (tab link)

We think it would have a lot more engagements if it conveyed fun or excitement. I know it's hard balancing that and keeping it something that our friends at Facebook will approve in terms of co-branding. Ideally, it could be a graphic without words to avoid l10n issues. Perhaps something involving the jewels? Or did they reject that idea before?

Let me know what you think. In terms of when we'd need it I guess that depends on when we launch the mainstream campaign, but hopefully your team will have time to help is in a sweet spot between the end of flicks creative work and the start of MWC. 

Thanks!

Comment 16

6 years ago
Thanks.

Yah, the jewels need to stay in the same exact orientation and I rather not mess with that.  Do you know roughly how long after we launch you'd need this second graphic? 

Ty, do you have some thoughts on how we can visualize social api that captures the excitement but doesn't lean so much on the existing graphics we have (fox hat, jewels, etc) ? you had a fun chat bubble collage before which we might be able to leverage here, otherwise we'll have to go abstract... any thoughts? 

Chelsea, I'm not sure if I can guarantee no text in the graphic :( truth is it really helps with these types of graphics, when we don't have a strong library of graphics to lean on... we can easily have an abstract background with some text to fill the space... but we'll do our best.
Assignee: ltom → tyronflanagan

Comment 17

6 years ago
If we have text, if we can get the text in advance (would Matej write it?) I can try to get it localized in as many locales as possible. But low text (ie: a few words) would be easier. Thanks all!
Cool. So what are our next steps here?

Comment 19

6 years ago
We'll have to explore a few ideas. Ty had done some initial work with chat bubbles, a collage of chat bubbles which we may be able to use towards this... though it's a departure from what we've been using so far and obviously a focus on the chat feature (which seems to be okay).  I think we have to have *some* text, but we'll keep it lean. 

Matej, and Ty, could you explore the chat bubble direction a little? it could be something simple and abstract in nature, but lets be sure it: feels somewhat familiar and ties back to the rest of the assets we've produced, and that it doens't break any of the strict fb brand guidelines we have. I'm happy to chat more about this.  But perhaps if we come up with a template with the chat bubbles, we can spin up a few different versions that can be used for follow-up posts. 

What is the anticipated due date here?
If there's text, then we'll need it 3 weeks before it's due to go live so that it can be localized. It's currently scheduled to go live a week after we launch the mainstream campaign. As for when that goes live, we were looking at mid January in our last meeting, but as you know that's still unconfirmed. So going with that, I'd say due around the 4th with room for flexibility.
Is there anything we could do with icons in the chat bubbles instead of words? Maybe something like question marks, emoticons and hearts (etc.). That could still communicate a lot while being universal and not needing localization (I also think it could be visually interesting).

Comment 22

5 years ago
Outdated / Outstanding bug - closing out.  
Please ping / re-open as needed.  Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.