Auto-complete doesn't scan for higher-level domains

VERIFIED FIXED

Status

SeaMonkey
Location Bar
--
enhancement
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: Mark, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

17 years ago
Mozilla build: 2001050921

Visit a web site that starts with www. such as http://www.mozilla.org
Then clear the URL bar and start typing mozilla.org
Since you have never visited http://mozilla.org the autocomplete should assume that the URL is 
preceded with:
http://www.

Reproducible: Everytime

Steps to reproduce:
1.Visit http://www.mozilla.org
2.Clear URL bar
3.Start typing mozilla.org in URL bar
4. notice how it doesn't auto-complete
5. Now visit http://mozilla.org
6. Start typing mozilla.org and notice how it auto-completes.

Actual Result:
Auto-complete doesn't assume the common http://www. prefix. Only when you visit the site without 
typing the www. does the auto-complete function complete the site.

Expected Result:
Auto-complete should have assumed the http://www. prefix for step 3 above so that you are taken to 
http://www.mozilla.org/

Extra info:
Not all sites can omit the preceding www.
If you have already visited http://mozilla.org then use another URL that is able to omit the preceding 
www. such as:
(www.)slashdot.org
(www.)cnn.com
(www.)zdnet.com

Comment 1

17 years ago
Assume is the wrong word.  Perhaps we should _offer_ matches w/in the domain, 
but we should not _assume_ www. 

Comment 2

17 years ago
This is sounding remarkably familiar to  a problem I once commented on, whereby
the old drop down autocomplete would store both www.mozilla.org and mozilla.org
and not be able to realise they were in fact the same site.

See Bug 57932 for details.

Can this be a duplicate? 
Is the autocomplete still the same code as back in BuildID: 2000102408 ??
(Reporter)

Comment 3

17 years ago
This auto-complete is actually new code. See bug 43189, it was introduced around
2001-04-30. This bug is not a duplicate of 57932. In fact bug 57932 may be
considered obsolete because of the new auto-complete code.

Comment 4

17 years ago
We already offer sites with the www. prefix.  That's bug 63421, which was fixed 
at the end of April.  Is this bug asking for the browser to prevent me from 
going to http://mozilla.org/ if I've already been to http://www.mozilla.org/?
(Reporter)

Comment 5

17 years ago
This is a duplicate of bug 63421. Added Joe Hewitt to CC for further action. 
Either bug 63421 should be reopened and this bug marked as duplicate or simply 
leave this bug open and confirm it.

Comment 6

17 years ago
We shouldn't be assuming that www.somesite.com and somesite.com are the same
thing.  The usually are, however there is no certainly (and certainly no law)
that these two sites are indeed the same.

IMHO autocomplete should not be equating the two.  www.somesite.com != somesite.com

Comment 7

17 years ago
> www.somesite.com != somesite.com

Ok.. taken.. but what about the times that www.somesite.com = somesite.com ?
Is there a nice simple way this can be tested for so that Moz only needs to 
store one of them? If it can be done.. I think it ought to be. If it can't be 
done... well... then someone isn't thinking creatively enough :)

Comment 8

17 years ago
Reporter could you clarify something? Are you sugggesting that autocomplete
"force" the http://www. on the URL? Or are you suggesting that it include
http://www. as one of the options on the drop down menu? If it is the later, as
of build 2001052904 win32 installer talkback, it is fixed.

Comment 9

17 years ago
or are you asking for bug 78268 ?
(Reporter)

Comment 10

17 years ago
TO _basic@yahoo.com:
No, I don't want to force the www prefix. I'm not happy with my orginal report, 
I don't want mozilla to assume the www prefix, only search for matches for a 
domain/sub-domain in the URL history. This problem is not fixed with Mozilla 
win32 build 2001060308 (lastest as of this writing)

Comment 11

17 years ago
Reporter: Could you change the summary to reflect your last post?
(Reporter)

Updated

17 years ago
Summary: Auto-complete doesn't assume the www URL prefix → Auto-complete doesn't scan for higher-level domains

Comment 12

17 years ago
Mark, I've downloaded build 2001060308 win32 sea installer talkback. It seems
that autocomplete does not work properly in the first browser window when
mozilla is executed ( a mostly blank drop down menu appears ). However, I've
noticed that it works in the second browser window. It seems to work quite well
too. The feature you are asking for is already there.

Comment 13

17 years ago
Build 2001061520 win32
Reporter: do you still see this bug?

I still can't reproduce the bug using your instructions.
(Reporter)

Comment 14

17 years ago
I'm using Milestone build 0.9.1 ID: 2001060703
This bug has been fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
marking VERIFIED Fixed... it should probablybe WFM but whatever...
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.