Closed Bug 799975 Opened 7 years ago Closed 7 years ago

build failure in firefox/media/webrtc/signaling/src/media/VcmSIPCCBinding.cpp with system nss

Categories

(Toolkit Graveyard :: Build Config, defect)

x86
Linux
defect
Not set

Tracking

(firefox18 fixed, firefox19 fixed)

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: ht990332, Assigned: glandium)

References

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121007185730

Steps to reproduce:

system nss 3.13.6
c++ -o src/media/VcmSIPCCBinding.o -c  -I../../../../dist/system_wrappers -include /home/hussam/packages/firefox/src/firefox/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -D_FILE_OFFSET_BITS=64 -DCHROMIUM_BUILD -DUSE_NSS=1 -DENABLE_ONE_CLICK_SIGNIN -DGTK_DISABLE_SINGLE_INCLUDES=1 -D_ISOC99_SOURCE=1 -DENABLE_REMOTING=1 -DENABLE_WEBRTC=1 -DENABLE_CONFIGURATION_POLICY -DENABLE_INPUT_SPEECH -DENABLE_NOTIFICATIONS -DENABLE_GPU=1 -DENABLE_EGLIMAGE=1 -DUSE_SKIA=1 -DENABLE_TASK_MANAGER=1 -DENABLE_WEB_INTENTS=1 -DENABLE_EXTENSIONS=1 -DENABLE_PLUGIN_INSTALLATION=1 -DENABLE_PROTECTOR_SERVICE=1 -DENABLE_SESSION_SERVICE=1 -DENABLE_THEMES=1 -DENABLE_BACKGROUND=1 -DENABLE_AUTOMATION=1 -DENABLE_PRINTING=1 -DENABLE_CAPTIVE_PORTAL_DETECTION=1 -DLOG4CXX_STATIC -D_NO_LOG4CXX -DUSE_SSLEAY -D_CPR_USE_EXTERNAL_LOGGER -DWEBRTC_RELATIVE_PATH -DHAVE_WEBRTC_VIDEO -DHAVE_WEBRTC_VOICE -DMOZILLA_INTERNAL_API -DSIP_OS_LINUX -D_GNU_SOURCE -DLINUX -DGIPS_VER=3510 -DSECLIB_OPENSSL -D__STDC_FORMAT_MACROS -DNDEBUG -DNVALGRIND -DDYNAMIC_ANNOTATIONS_ENABLED=0 -I. -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//.. -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/callcontrol -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/common -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/common/browser_logging -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/media -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/media-conduit -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/mediapipeline -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/softphonewrapper -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/peerconnection -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./include -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/sipcc/include -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/sipcc/cpr/include -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../../../nsprpub/pr/include -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../../../ipc/chromium/src -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../../../ipc/chromium/src/base/third_party/nspr -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../../../xpcom/base -I../../../../dist/include -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../../../dom/base -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../../../media/mtransport -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../trunk/src -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../trunk/src/video_engine/include -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../trunk/src/voice_engine/include -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../trunk/src/modules/interface -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../trunk/src/peerconnection -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../../../netwerk/srtp/src/include -I/home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//../../../netwerk/srtp/src/crypto/include  -fPIC  -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Werror=conversion-null -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -Wno-long-long -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks  -fomit-frame-pointer -Werror -m32 -mmmx    -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -MD -MF .deps/VcmSIPCCBinding.o.pp  /home/hussam/packages/firefox/src/firefox/media/webrtc/signaling/src/media/VcmSIPCCBinding.cpp
In file included from /home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/mediapipeline/SrtpFlow.h:10:0,
                 from /home/hussam/packages/firefox/src/firefox/media/webrtc/signaling//./src/mediapipeline/MediaPipeline.h:19,
                 from /home/hussam/packages/firefox/src/firefox/media/webrtc/signaling/src/media/VcmSIPCCBinding.cpp:49:
../../../../dist/system_wrappers/ssl.h:3:22: fatal error: ssl.h: No such file or directory
compilation terminated.
make[7]: *** [src/media/VcmSIPCCBinding.o] Error 1
make[7]: Leaving directory `/home/hussam/packages/firefox/src/firefox/obj-i686-pc-linux-gnu/media/webrtc/signaling/signaling_ecc'
make[6]: *** [signaling_ecc_libs] Error 2
make[6]: Leaving directory `/home/hussam/packages/firefox/src/firefox/obj-i686-pc-linux-gnu/media/webrtc/signaling'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/home/hussam/packages/firefox/src/firefox/obj-i686-pc-linux-gnu/media/webrtc'
make[4]: *** [libs_tier_platform] Error 2
make[4]: Leaving directory `/home/hussam/packages/firefox/src/firefox/obj-i686-pc-linux-gnu'
make[3]: *** [tier_platform] Error 2
make[3]: Leaving directory `/home/hussam/packages/firefox/src/firefox/obj-i686-pc-linux-gnu'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/home/hussam/packages/firefox/src/firefox/obj-i686-pc-linux-gnu'
make[1]: *** [realbuild] Error 2
make[1]: Leaving directory `/home/hussam/packages/firefox/src/firefox'
make: *** [build] Error 2
WebRTC depends on libssl/NSS 3.14 features (in particular DTLS). 

Install a system NSS of 3.14 (or 3.14 beta) and retry.  I don't know if we can key off the version of system NSS in our build system.
Component: Untriaged → Build Config
Product: Firefox → Toolkit
The problem is missing NSS_CFLAGS somewhere in media/webrtc.
I have a similar error on src/sipcc/core/ccapp/capability_set.o, for prcpucfg.h
(In reply to Mike Hommey [:glandium] from comment #3)
> I have a similar error on src/sipcc/core/ccapp/capability_set.o, for
> prcpucfg.h

(on aurora)
Attachment #672223 - Flags: review?(khuey)
Assignee: nobody → mh+mozilla
Adding ted since he wrote this
Status: UNCONFIRMED → NEW
Ever confirmed: true
I don't know that we want to put it in like that as a blanket statement. We should probably be putting this in the .gyp files that require these.
(In reply to Ted Mielczarek [:ted] from comment #7)
> I don't know that we want to put it in like that as a blanket statement. We
> should probably be putting this in the .gyp files that require these.

Using make variable in gyp files seems... weird.
That seems ugly, but that seems to work.
Attachment #672265 - Flags: review?(ted.mielczarek)
Attachment #672223 - Attachment is obsolete: true
Attachment #672223 - Flags: review?(khuey)
I explicitly made make variables in gyp files work because it was the simplest path to make things like $(NSPR_CFLAGS) work.
This actually works
Attachment #672282 - Flags: review?(ted.mielczarek)
Attachment #672265 - Attachment is obsolete: true
Attachment #672265 - Flags: review?(ted.mielczarek)
Attachment #672282 - Flags: review?(ted.mielczarek) → review+
https://hg.mozilla.org/mozilla-central/rev/17ee39da56c8
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 672282 [details] [diff] [review]
Fix webrtc when building with system nspr/nss

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 792188
User impact if declined: Build error when building with system nspr/nss (typically, linux distros)
Testing completed (on m-c, etc.): Landed on m-c
Risk to taking this patch (and alternatives if risky): Essentially a no-op for tinderbox builds. Low risk.
String or UUID changes made by this patch: None
Attachment #672282 - Flags: approval-mozilla-aurora?
Attachment #672282 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 776877
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.