Random crashes in NECKO.DLL

VERIFIED DUPLICATE of bug 71397

Status

()

Core
Networking: File
--
critical
VERIFIED DUPLICATE of bug 71397
17 years ago
16 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: dougt)

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'm suffering slightly from random crashes in NECKO.DLL (usually the first time
I mouse over the toolbar or a cascading menu but I can't be sure). When the
crash occurs I get a standard Windows 95 crash dialog as follows:

MOZILLA caused an invalid page fault in
module NECKO.DLL at 0157:6078475a.
Registers:
EAX=00000000 CS=0157 EIP=6078475a EFLGS=00010202
EBX=02e95e60 SS=015f ESP=0319fe00 EBP=0319fe34
ECX=60e9c5c0 DS=015f ESI=80000000 FS=137f
EDX=0319fe24 ES=015f EDI=02e95980 GS=0000
Bytes at CS:EIP:
8b 08 ff 51 6c 85 c6 89 45 08 75 09 8b 45 f0 85 
Stack dump:
00000000 0319fe24 02e95e10 02e95e10 60db3080 bff767f7 bffc14a0 0319ffcc
bff76841 816bd4d8 bff7f64d 816bd4d8 00000001 0319ff10 6077456f 00000000 

although Mozilla appears to continue running happily in the background if the
crash dialog is moved out of the way (in fact that's how I'm able to paste the
crash message in :-)

I stopped using talkback builds because the reports never seemed to get sent to
your server, but I have Visual C++ 5.0 and I'm willing to provide any data that
I can collect.
Reporter: 
Which build are you using ?
Have you deleted the old bin directory before you installed the new build ?
Can you try it with a talkback ?
I have no problems with talkback and it´s sending the reports the most time 
without any problems. After talkback submitted the crash you must run 
talkback.exe (somewhere in your mozilla/bin/.. directory) manually to get the 
Talkback ID.

It´s difficult to understand this crash without a stack trace or with clear 
steps to reproduce the crash.
You must build mozilla yourself (a debug build) that you can poste a stack 
trace. (see www.mozilla.org/build for details).
I´m using mozilla (own build) on win2k and I haven´t seen this crash in the last 
weeks.

Can you try it to the first with a new profile ?
(run "mozilla -profilemanager").
Please delete also "mozregistry.dat" (on NT : C:\winnt\).
Please add a comment if a new profile fix this crash.
(Reporter)

Comment 2

17 years ago
I tried a new profile but that didn't help.
I haven't tried deleting mozregistry.dat yet.
The stack trace as given by VC++ 5.0 is
NECKO! 6078475a()
NECKO! 6077456f()
NECKO! 6077968e()
I assume I've got a release build, my PC is quite old and the hard disk is full
which precludes compiling Mozilla myself :-( unless you know where I can get one.
I'll see if I can get talkback to work next week.

Comment 3

17 years ago
updating component
really updating component...
Assignee: asa → neeti
Component: Browser-General → Networking
QA Contact: doronr → tever

Updated

17 years ago
Keywords: qawanted

Updated

17 years ago
Severity: minor → critical
Keywords: crash

Comment 5

17 years ago
Reporter: can you reproduce these with the latest builds? A lot of changes went 
in over the weekend.
(Reporter)

Comment 6

17 years ago
I got bitten by bug 80407 so I'm having to download another nightly.
(Reporter)

Comment 7

17 years ago
Still no luck downloading nightlies but I am submitting this with Mozilla Build
ID: 2001050515 having succesfully crashed giving a talkback ID of TB30472065Z :-)

Comment 8

17 years ago
from talkback:

nsFileIO::Open  [d:\builds\seamonkey\mozilla\netwerk\base\src\nsFileStreams.cpp,
line 156]
nsFileTransport::Process
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsFileTransport.cpp, line 640]
 

Comment 9

17 years ago
-->file
Assignee: neeti → dougt
Component: Networking → Networking: File
(Assignee)

Comment 10

17 years ago
dup.

*** This bug has been marked as a duplicate of 71397 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 11

16 years ago
VERIFIED:
The bug that was duped to has similar problems and is VERIFIED.
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.