session cookies aren't being set; broken in 0.9

RESOLVED DUPLICATE of bug 79851

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 79851
17 years ago
13 years ago

People

(Reporter: Thad Humphries, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I just installed Mozilla 0.9 on a WinNT 4 box to see if you fixed my problems
with applets that use multiple JARs (see Bugzilla #52714). However I can't get
into my system.  Apparently, the session cookie that Tomcat tries to set isn't
being allowed although I have 'accept all cookies' checked.

Go to the given URL.  In the applet created in the small window, type the user
'demo' and passwd 'demo'.  Click logon.  The server will attempt to set a
session cookie.  However, this fails and you get the login applet in the main
window.  This logon has worked with all versions of Mozilla from 0.6 thru 0.8.1
on Windows and Linux.  It works with IE 5.5 Win.

Comment 1

17 years ago
I've been seeing some weirdness at http://mail.yahoo.com which made me suspect
that mozilla wasn't handling cookies right.
Namely that sometimes, after logging out (with the "sign out completely" link)
I'd return to the main page (with the "return to yahoo mail" link) and get my
inbox instead of a login screen. Shortly after that I started getting prompted
for a password and not a user name.

However, I haven't seen this yet on my current build (2001050910/Linux) so it
may've been fixed shortly after 0.9. I'll comment here if I see it again.

Comment 2

17 years ago
Just saw the yahoo mail problem again but, from looking at the cookie manager,
I'm inclined to believe that it's a cache issue rather than a cookie issue and,
hence, unrelated to this bug (in other words, ignore my comments here and sorry
about the spam).

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 79851 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.