Closed Bug 800203 Opened 7 years ago Closed 7 years ago

[camera][GP][Unagi] Camera shows major graphical glitch right after taking a picture

Categories

(Core :: DOM: Core & HTML, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 799801
blocking-b2g -

People

(Reporter: marcia, Assigned: mikeh)

References

Details

(Keywords: smoketest, unagi, Whiteboard: [dogfood-blocker], [MWCDemo2013], testrun 2, testrun 4)

Attachments

(3 files)

Testing with unagi device

b2g revision=ca1f327d5acc198bb4be62fa51db2c039032c9ce
gaia remote=b2g" revision="58e2582ba479e4334fddfc2e759b474e74b7f52d
gecko remote=mozilla revision=e0fb02b979b3109057ceeedd2011516522d4ad29
gonk-misc remote=b2g" revision=8c3562dbbc63813fbb2c433a8714904d6cb17ae8

STR:
1. Invoke the camera app to take a picture
2. Observe a graphical glitch right after taking a picture.

Does not happen with Otoro device using the same build.
This is very reproducible.  Marked blocking, but not critical for dogfooding.
blocking-basecamp: --- → +
Attached image Picture of the issue
I happened to take a shot of what it looks like when I stumbled on this yesterday.
Mike, I believe this is for you?
Component: Gaia → DOM: Core & HTML
OS: Mac OS X → Gonk
Product: Boot2Gecko → Core
Hardware: x86 → ARM
Whoah.  Will take a look once my Unagi arrives.
Assignee: nobody → mhabicher
Duplicate of this bug: 803360
There is a screenshot of the issue in 803360, but if will be very easy to repro once you get the phone.
Duplicate of this bug: 803423
Duplicate of this bug: 803576
Duplicate of this bug: 804882
Whiteboard: [dogfood-blocker]
Duplicate of this bug: 807837
Bug 799801 marked WONTFIX due to unagi-specific driver bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799801
This is duped to a WONTFIX, so presumably it shouldn't be blocking-basecamp+ anymore, right?
blocking-basecamp: + → ?
blocking-basecamp: ? → ---
This issue repros in Ungia, build 20130104070203 v.1.0
The freeze frame photo is highly pixilated  for Test case #2298 no reboot required.
Repros in 3/3 devices 10/10 times including screen shot of issues in attachment
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
UCID: camera-001
https://moztrap.mozilla.org/results/case/61423/
Whiteboard: [dogfood-blocker] → [dogfood-blocker], testrun 2
Known issue.  Please see above comments.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WONTFIX
Issue repros on build 20130115070201 December 5th Kernel however is noted that this issue will not be fixed
Yes -- per bug 799801 comment 12, this is a driver issue and not something that we have control over, I believe.

Quoting that comment here, since (despite comment 16) I don't think this has actually been explained on this bug yet:
(Quoting Mike Habicher [:mikeh] from bug 799801 comment 12)
> (The garbled postview image is probably because the postview on Unagi is
> configured to use 426x320 frames, different from the 480x320 used by the
> preview frames.  This size is chosen internally by the driver, and not
> exposed for tweaking.)
(and per bug 799801 comment 10, please reopen if you can reproduce this on anything _other_ than unagi)
Whiteboard: [dogfood-blocker], testrun 2 → [dogfood-blocker], testrun 2, testrun 4
(In reply to Daniel Holbert [:dholbert] from comment #19)
> (and per bug 799801 comment 10, please reopen if you can reproduce this on
> anything _other_ than unagi)

Hi Daniel,

I am able to replicate this issue on the Keon Geeksphone released at Campus Party Brasil this past week. It is running version 2013/01/24 of Firefox OS.

More information on the Geeksphone Developer Preview running Firefox OS at:
http://www.geeksphone.com/

Please let me know if you have any questions.

Thanks!!
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
I am seeing the exact same issue on the keon geeksphone, with the following build

Gaia   21cedfd1787f4aff26721fc0f160e771db5cd67d
BuildID 20130211030117
Version 18.0
Whiteboard: [dogfood-blocker], testrun 2, testrun 4 → [dogfood-blocker], [MWCDemo2013], testrun 2, testrun 4
Summary: [camera] Camera shows major graphical glitch right after taking a picture → [camera][GP][Unagi] Camera shows major graphical glitch right after taking a picture
I am also experiencing this problem. I'm on a Turkcell Maxiplus phone, Boot2Gecko 1.0.1.0-prerelease, build identifier 20130219070200. Not sure if that's the relevant system information.
Timothy, that's the same phone as Unagi, not a blocker.
blocking-b2g: tef? → -
Per comment 22, this affects the keon Geeksphone as well (not just unagi)...
Looks like the Geeksphone camera driver has the same issue as Unagi.  We need a new version of the driver from the hardware vendor to fix this.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799801
You need to log in before you can comment on or make changes to this bug.