PR_Assert (s=0xff248ae8 "!mEnumerating" - Program received signal SIGABRT, Aborted.

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
critical
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({crash})

Trunk
Sun
Solaris
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
5/9's morning cvs build [xlib, solaris7sparc]. 
NS_ProcessTimeouts() lives!
Start reading in bookmarks.html
Finished reading in bookmarks.html  (79600 microseconds)
WEBSHELL+ = 3
Creating a new nsIToolkit!
Enabling Quirk StyleSheet
Creating a new nsIToolkit!
###!!! ASSERTION: nsImageXlib::DrawToImage not yet implemented: 'Not Reached', 
file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
###!!! Break: at file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
Creating a new nsIToolkit!
Enabling Quirk StyleSheet
###!!! ASSERTION: nsImageXlib::DrawToImage not yet implemented: 'Not Reached', 
file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
###!!! Break: at file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
###!!! ASSERTION: nsImageXlib::DrawToImage not yet implemented: 'Not Reached', 
file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
###!!! Break: at file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
###!!! ASSERTION: nsImageXlib::DrawToImage not yet implemented: 'Not Reached', 
file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
###!!! Break: at file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
blank
###!!! ASSERTION: nsImageXlib::DrawToImage not yet implemented: 'Not Reached', 
file /tmp/mozilla/gfx
/src/xlib/nsImageXlib.cpp, line 1093
###!!! Break: at file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
###!!! ASSERTION: nsImageXlib::DrawToImage not yet implemented: 'Not Reached', 
file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
###!!! Break: at file /tmp/mozilla/gfx/src/xlib/nsImageXlib.cpp, line 1093
Document 
http://www.mozilla.org/quality/browser/debugtc/bft_browser_html_mix3.html 
loaded successfully
!!!Object wrapped by XPConnect has members whose names shadow each other!!!
   XPCNativeSet @ 0x73b3d0 for the class:
   classname: HTMLCollection
   contractid: <unknown>
   claims to implement interfaces:
      nsISupports
      nsIDOMNodeList
      nsIDOMHTMLCollection
nsIDOMNodeList::item shadows nsIDOMHTMLCollection::item
nsIDOMNodeList::length shadows nsIDOMHTMLCollection::length
Creating a new nsIToolkit!
WEBSHELL+ = 4
Creating a new nsIToolkit!
WEBSHELL+ = 5
Creating a new nsIToolkit!
Warning prev sibling is not in our list!!![New LWP    9        ]
Creating a new nsIToolkit!
/content/pref/pref-navigator.xul
Creating a new nsIToolkit!
/content/pref/pref-appearance.xul
Creating a new nsIToolkit!
/content/pref/pref-fonts.xul
Creating a new nsIToolkit!
/content/pref/pref-navigator.xul
Creating a new nsIToolkit!
/content/pref/pref-history.xul
Creating a new nsIToolkit!
/content/pref/pref-debug.xul
Creating a new nsIToolkit!
/content/pref/pref-debug1.xul
Creating a new nsIToolkit!
/content/pref/pref-debug2.xul
Creating a new nsIToolkit!
/content/pref/pref-debug1.xul
Creating a new nsIToolkit!
/content/pref/pref-debug2.xul
Creating a new nsIToolkit!
/content/pref/pref-offline.xul
Creating a new nsIToolkit!
/content/pref/pref-advanced.xul
frame: Box (a5c1e4) style: a2c7d0 {
  * weight: 0 { display: 18[0x12]enum }
  * weight: 0 { -moz-user-focus: 1[0x1]enum }
  treechildren weight: 1 { -moz-user-focus: none }
  treechildren weight: 1 { display: 22[0x16]enum }
  treechildren weight: 1 { }
  treeitem > treechildren weight: 2 { display: none }
  treeitem[open=true] > treechildren weight: 258 { display: 22[0x16]enum }
}
Wrong parent style context:  style: 9d1520 {
  * weight: 0 { display: 18[0x12]enum }
  * weight: 0 { -moz-user-focus: 1[0x1]enum }
  treeitem weight: 1 { display: 22[0x16]enum }
  treeitem weight: 1 { }
  treeitem weight: 1 { -moz-binding: 
url("chrome://global/content/treeBindings.xml#treeitem") }
  treeitem weight: 1 { list-style-image: none }
}
should be using:  style: 995ee0 {
  * weight: 0 { display: 18[0x12]enum }
  * weight: 0 { -moz-user-focus: 1[0x1]enum }
  treeitem weight: 1 { display: 22[0x16]enum }
  treeitem weight: 1 { }
  treeitem weight: 1 { -moz-binding: 
url("chrome://global/content/treeBindings.xml#treeitem") }
  treeitem weight: 1 { list-style-image: none }
}

Creating a new nsIToolkit!
/content/pref-mailnews.xul
Creating a new nsIToolkit!
/content/pref-composer.xul
Creating a new nsIToolkit!
/content/pref/pref-search.xul
Creating a new nsIToolkit!
Creating a new nsIToolkit!
/content/pref/pref-applications.xul
###!!! ASSERTION: no script global object: 'mScriptGlobalObject != nsnull', 
file /tmp/mozilla/content/xul/document/src/nsXULDocument.cpp, line 5144
###!!! Break: at file /tmp/mozilla/content/xul/document/src/nsXULDocument.cpp, 
line 5144
###!!! ASSERTION: no document: 'doc != nsnull', file 
/tmp/mozilla/content/xul/document/src/nsXULDocument.cpp, line 5314
###!!! Break: at file /tmp/mozilla/content/xul/document/src/nsXULDocument.cpp, 
line 5314
###!!! ASSERTION: OnStopRequest failed: 'NS_SUCCEEDED(rv)', file 
/tmp/mozilla/netwerk/protocol/jar/src/nsJARChannel.cpp, line 585
###!!! Break: at file /tmp/mozilla/netwerk/protocol/jar/src/nsJARChannel.cpp, 
line 585
/content/pref/pref-smart_browsing.xul
Creating a new nsIToolkit!
###!!! ASSERTION: win is null.  this happens [often on xlib builds].  see bug 
#79213: 'win', file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! Break: at file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! ASSERTION: win is null.  this happens [often on xlib builds].  see bug 
#79213: 'win', file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! Break: at file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! ASSERTION: win is null.  this happens [often on xlib builds].  see bug 
#79213: 'win', file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! Break: at file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! ASSERTION: win is null.  this happens [often on xlib builds].  see bug 
#79213: 'win', file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! Break: at file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! ASSERTION: win is null.  this happens [often on xlib builds].  see bug 
#79213: 'win', file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! Break: at file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! ASSERTION: win is null.  this happens [often on xlib builds].  see bug 
#79213: 'win', file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
###!!! Break: at file /tmp/mozilla/content/events/src/nsEventStateManager.cpp, 
line 483
Assertion failure: !mEnumerating, at /tmp/mozilla/xpcom/ds/nsHashtable.cpp:279

Program received signal SIGABRT, Aborted.
0xfedf9e54 in __sigprocmask () from /usr/lib/libthread.so.1
(gdb) bt
#0  0xfedf9e54 in __sigprocmask () from /usr/lib/libthread.so.1
#1  0xfedef3f4 in _resetsig () from /usr/lib/libthread.so.1
#2  0xfedeeb18 in _sigon () from /usr/lib/libthread.so.1
#3  0xfedf1a28 in _thrp_kill () from /usr/lib/libthread.so.1
#4  0xfed395b0 in abort () from /usr/lib/libc.so.1
#5  0xfeee5378 in PR_Assert (s=0xff248ae8 "!mEnumerating",
    file=0xff248a78 "/tmp/mozilla/xpcom/ds/nsHashtable.cpp", ln=279)
    at /tmp/mozilla/nsprpub/pr/src/io/prlog.c:477
#6  0xff112f98 in nsHashtable::Put (this=0xa2b598, aKey=0xffbe80b8, 
aData=0xa32c70)
    at /tmp/mozilla/xpcom/ds/nsHashtable.cpp:279
#7  0xff1146c0 in nsSupportsHashtable::Put (this=0xa2b598, aKey=0xffbe80b8, 
aData=0xa32c70,
    value=0x0) at /tmp/mozilla/xpcom/ds/nsHashtable.cpp:664
#8  0xfcc7f414 in nsBindingManager::SetBinding (this=0xa0cc70, 
aContent=0xb44300,
    aBinding=0xa32c70) at /tmp/mozilla/content/xbl/src/nsBindingManager.cpp:528
#9  0xfcc77bec in nsXBLService::LoadBindings (this=0x474220, aContent=0xb44300, 
aURL=@0xa3390c,
    aAugmentFlag=0, aBinding=0xffbe8418, aResolveStyle=0xffbe83fc)
    at /tmp/mozilla/content/xbl/src/nsXBLService.cpp:700
#10 0xfc270678 in nsCSSFrameConstructor::ConstructFrameInternal (this=0x9a82a8,
    aPresShell=0xa94f98, aPresContext=0xaff4e0, aState=@0xffbe92e8, 
aContent=0xb44300,
    aParentFrame=0xb85104, aTag=0x36e980, aNameSpaceID=6, 
aStyleContext=0xa59100,
    aFrameItems=@0xffbe8728, aXBLBaseTag=0)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:7192
#11 0xfc270428 in nsCSSFrameConstructor::ConstructFrame (this=0x9a82a8, 
aPresShell=0xa94f98,
    aPresContext=0xaff4e0, aState=@0xffbe92e8, aContent=0xb44300, 
aParentFrame=0xb85104,
    aFrameItems=@0xffbe8728) at 
/tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:7153
#12 0xfc26b274 in nsCSSFrameConstructor::CreateAnonymousFrames (this=0x9a82a8,
    aPresShell=0xa94f98, aPresContext=0xaff4e0, aState=@0xffbe92e8, 
aParent=0xb35008,
    aDocument=0x9e99a0, aParentFrame=0xb85104, aChildItems=@0xffbe8728)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:5257
#13 0xfc26dc08 in nsCSSFrameConstructor::BuildGfxScrollFrame (this=0x9a82a8, 
aPresShell=0xa94f98,
    aPresContext=0xaff4e0, aState=@0xffbe92e8, aContent=0xb35008, 
aDocument=0x9e99a0,
    aParentFrame=0xb84fb0, aStyleContext=0x991960, aIsRoot=0, 
aNewFrame=@0xffbe8734,
    aAnonymousFrames=@0xffbe8728, aScrollPortFrame=0xb851ac)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:6162
#14 0xfc26d588 in nsCSSFrameConstructor::BeginBuildingScrollFrame 
(this=0x9a82a8,
    aPresShell=0xa94f98, aPresContext=0xaff4e0, aState=@0xffbe92e8, 
aContent=0xb35008,
    aContentStyle=0x991960, aParentFrame=0xb84fb0, aScrolledPseudo=0x36c750, 
aDocument=0x9e99a0,
    aIsRoot=0, aNewFrame=@0xffbe89f8, aScrolledChildStyle=@0xffbe87d0,
    aScrollableFrame=@0xffbe87ec, aScrollPortFrame=0x0)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:5958
#15 0xfc26da10 in nsCSSFrameConstructor::BuildScrollFrame (this=0x9a82a8, 
aPresShell=0xa94f98,
    aPresContext=0xaff4e0, aState=@0xffbe92e8, aContent=0xb35008, 
aContentStyle=0x991960,
    aScrolledFrame=0xb85d5c, aParentFrame=0xb84fb0, aNewFrame=@0xffbe89f8,
    aScrolledContentStyle=@0xffbe8a94, aScrollPortFrame=0x0)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:6107
#16 0xfc26c36c in nsCSSFrameConstructor::ConstructXULFrame (this=0x9a82a8, 
aPresShell=0xa94f98,
    aPresContext=0xaff4e0, aState=@0xffbe92e8, aContent=0xb35008, 
aParentFrame=0xb84fb0,
    aTag=0x36aeb0, aNameSpaceID=6, aStyleContext=0x991960, 
aFrameItems=@0xffbe8f18, aXBLBaseTag=0,
    aHaltProcessing=@0xffbe8b20)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:5589
#17 0xfc270ce0 in nsCSSFrameConstructor::ConstructFrameInternal (this=0x9a82a8,
    aPresShell=0xa94f98, aPresContext=0xaff4e0, aState=@0xffbe92e8, 
aContent=0xb35008,
    aParentFrame=0xb84fb0, aTag=0x36aeb0, aNameSpaceID=6, 
aStyleContext=0x991960,
    aFrameItems=@0xffbe8f18, aXBLBaseTag=0)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:7253
#18 0xfc270428 in nsCSSFrameConstructor::ConstructFrame (this=0x9a82a8, 
aPresShell=0xa94f98,
    aPresContext=0xaff4e0, aState=@0xffbe92e8, aContent=0xb35008, 
aParentFrame=0xb84fb0,
    aFrameItems=@0xffbe8f18) at 
/tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:7153
#19 0xfc283630 in nsCSSFrameConstructor::ProcessChildren (this=0x9a82a8, 
aPresShell=0xa94f98,
    aPresContext=0xaff4e0, aState=@0xffbe92e8, aContent=0xb79f98, 
aFrame=0xb84fb0,
    aCanHaveGeneratedContent=0, aFrameItems=@0xffbe8f18, aParentIsBlock=0, 
aTableCreator=0x0)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:11295
#20 0xfc26d28c in nsCSSFrameConstructor::ConstructXULFrame (this=0x9a82a8, 
aPresShell=0xa94f98,
    aPresContext=0xaff4e0, aState=@0xffbe92e8, aContent=0xb79f98, 
aParentFrame=0xaab178,
    aTag=0x36a160, aNameSpaceID=6, aStyleContext=0xb60728, 
aFrameItems=@0xffbe9498, aXBLBaseTag=0,
    aHaltProcessing=@0xffbe9070)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:5877
#21 0xfc270ce0 in nsCSSFrameConstructor::ConstructFrameInternal (this=0x9a82a8,
    aPresShell=0xa94f98, aPresContext=0xaff4e0, aState=@0xffbe92e8, 
aContent=0xb79f98,
    aParentFrame=0xaab178, aTag=0x36a160, aNameSpaceID=6, 
aStyleContext=0xb60728,
    aFrameItems=@0xffbe9498, aXBLBaseTag=0)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:7253
#22 0xfc270428 in nsCSSFrameConstructor::ConstructFrame (this=0x9a82a8, 
aPresShell=0xa94f98,
    aPresContext=0xaff4e0, aState=@0xffbe92e8, aContent=0xb79f98, 
aParentFrame=0xaab178,
    aFrameItems=@0xffbe9498) at 
/tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:7153
#23 0xfc277af4 in nsCSSFrameConstructor::ContentInserted (this=0x9a82a8, 
aPresContext=0xaff4e0,
    aContainer=0xac6ae8, aChild=0xb79f98, aIndexInContainer=0, 
aFrameState=0xb1a668)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:8632
#24 0xfc282fc4 in nsCSSFrameConstructor::RecreateFramesForContent 
(this=0x9a82a8,
    aPresContext=0xaff4e0, aContent=0xb79f98)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:11154
#25 0xfc27da88 in nsCSSFrameConstructor::AttributeChanged (this=0x9a82a8, 
aPresContext=0xaff4e0,
    aContent=0xb79f98, aNameSpaceID=0, aAttribute=0x36a230, aHint=3)
    at /tmp/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:9944
#26 0xfcd2de60 in StyleSetImpl::AttributeChanged (this=0x9d0ba8, 
aPresContext=0xaff4e0,
    aContent=0xb79f98, aNameSpaceID=0, aAttribute=0x36a230, aHint=-1)
    at /tmp/mozilla/content/base/src/nsStyleSet.cpp:1289
#27 0xfc1c8838 in PresShell::AttributeChanged (this=0xa94f98, 
aDocument=0x9e99a0,
    aContent=0xb79f98, aNameSpaceID=0, aAttribute=0x36a230, aHint=-1)
    at /tmp/mozilla/layout/html/base/src/nsPresShell.cpp:4864
#28 0xfcbe85f4 in nsXULDocument::AttributeChanged (this=0x9e99a0, 
aElement=0xb79f98,
    aNameSpaceID=0, aAttribute=0x36a230, aHint=-1)
    at /tmp/mozilla/content/xul/document/src/nsXULDocument.cpp:1595
#29 0xfcbc1090 in nsXULElement::SetAttribute (this=0xb79f98, 
aNodeInfo=0xaefcb8,
    aValue=@0xffbe9e58, aNotify=1) at 
/tmp/mozilla/content/xul/content/src/nsXULElement.cpp:3064
#30 0xfcbc1350 in nsXULElement::SetAttribute (this=0xb79f98, aNameSpaceID=0, 
aName=0x36a230,
    aValue=@0xffbe9e58, aNotify=1) at 
/tmp/mozilla/content/xul/content/src/nsXULElement.cpp:3085
#31 0xfc32ee58 in nsMenuFrame::MarkAsGenerated (this=0xaab178)
Severity: normal → critical
Keywords: crash
(Assignee)

Updated

17 years ago
Blocks: 79119
Over to you, timeless, looks like more of your xlib build problems, there's
nothing wrong with the code on the stack here, something must be severly broken
in your build.
Assignee: jst → timeless

Comment 2

16 years ago
I suggested that this bug should be closed.
I reproduce this bug successful,but it is running ok!
(Assignee)

Comment 3

16 years ago
... bug 108122 has a similar stack ...

Comment 4

15 years ago
Antonio Xu suggested 15 months ago that this bug should be closed because it is
not reproducible anymore, and the "similar" crash is marked as fixed now (did
not happen anymore a year ago.
Can anybody still reproduce this?
It probably should be resolved as WFM. Anybody opposed?
Ok.

/be
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.