Last Comment Bug 800373 - Change marketplace strings to 'Firefox Marketplace'
: Change marketplace strings to 'Firefox Marketplace'
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: Web Apps (show other bugs)
: 16 Branch
: ARM Android
: -- normal (vote)
: Firefox 19
Assigned To: Nobody; OK to take it and work on it
:
: Myk Melez [:myk] [@mykmelez]
Mentors:
: 798538 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 07:42 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2016-07-29 14:29 PDT (History)
7 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified


Attachments
patch (5.37 KB, patch)
2012-10-11 07:42 PDT, Mark Finkle (:mfinkle) (use needinfo?)
wjohnston2000: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2012-10-11 07:42:03 PDT
Created attachment 670389 [details] [diff] [review]
patch

Mozilla is re-branding the App Marketplace to "Firefox Marketplace".

This patch changes the 3 strings and bumps entities.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-13 12:11:19 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6188fd032b93
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-13 12:16:35 PDT
Comment on attachment 670389 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Mozilla Marketplace was rebranded to Firefox Marketplace and we need to update the brnading in-product.
Testing completed (on m-c, etc.): landed on inbound
Risk to taking this patch (and alternatives if risky): low risk, strings only
String or UUID changes made by this patch: yes
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-10-13 16:39:10 PDT
https://hg.mozilla.org/mozilla-central/rev/6188fd032b93
Comment 4 Alex Keybl [:akeybl] 2012-10-15 12:01:32 PDT
Comment on attachment 670389 [details] [diff] [review]
patch

[Triage Comment]
This change has been correctly made with an entity bump, and is a requirement for the Marketplace. I'll communicate it to dev-l10n.

Do we need this in FF17 as well Mark?
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-15 12:15:59 PDT
(In reply to Alex Keybl [:akeybl] from comment #4)

> Do we need this in FF17 as well Mark?

Nope. We are turning it off for Fx17.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-15 12:38:57 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/76579b41994a
Comment 7 Axel Hecht [:Pike] 2012-10-15 19:01:27 PDT
Why did this land on aurora when bug 798538 said it's fine for 19?
Comment 8 Jason Smith [:jsmith] 2012-10-15 19:14:22 PDT
*** Bug 798538 has been marked as a duplicate of this bug. ***
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-16 07:40:29 PDT
(In reply to Axel Hecht [:Pike] (back Oct 29) from comment #7)
> Why did this land on aurora when bug 798538 said it's fine for 19?

Unfortunately, many other people were not fine with it riding on Fx19. The Marketplace team is highly focused on using Firefox 18 for Android as the initial launch vehicle and Marketing pushed very hard to get the "Firefox Marketplace" re-branding landed. It was a compromise to avoid the potential for string changes in Beta and beyond.

Note You need to log in before you can comment on or make changes to this bug.